Update all Reset Firefox strings and relevant UI to reflect improved copy

VERIFIED FIXED in Firefox 35

Status

()

Firefox
General
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: adw, Assigned: markh)

Tracking

Trunk
Firefox 35
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxgrowth])

Attachments

(5 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
Broken down from bug 1062345.

There's already bug 891095, but that's a broader bug about improving the dialog in general, e.g., moving it to content.  This bug is only about changing the strings and XUL as necessary to match the "user flow 2" dialog in the spec in the breakdown bug 1062345.

I'm adding a dependency on bug 1027884, but the spec doesn't say that the wording is still undecided.

This bug could maybe be broken down even more into strings and changing the XUL, but that seems unnecessary.
(Reporter)

Comment 1

3 years ago
(In reply to Drew Willcoxon :adw from comment #0)
> I'm adding a dependency on bug 1027884, but the spec doesn't say that the
> wording is still undecided.

Actually the spec says "possibly 'Refresh'".  I asked for a decision in bug 1027884.

Updated

3 years ago
Flags: qe-verify?
Flags: firefox-backlog+
(Reporter)

Comment 2

3 years ago
Let's broaden this bug to change all Reset Firefox strings and relevant UI in the app, not only the Reset Firefox dialog.

I did the following searches through .properties and DTD files:

http://mxr.mozilla.org/mozilla-central/search?string=reset+%25&find=\.properties%24&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central

http://mxr.mozilla.org/mozilla-central/search?string=reset+%26&find=\.dtd%24&findi=&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central

And came up with the following places that "reset" is used:

---

http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/resetProfile.properties

Relevant strings:

* resetProfile.resetButton.label

Used by:

* Reset Firefox notification bar: http://mxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserGlue.js#637

---

http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/safeMode.dtd

Relevant strings:

* resetProfile.label
* resetProfileInstead.label
* autoSafeModeDescription2.label
* resetProfileFooter.label

Used by:

* Safe mode dialog: http://mxr.mozilla.org/mozilla-central/source/browser/base/content/safeMode.xul

---

http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/resetProfile.dtd

Relevant strings:

* resetProfile.dialog.title
* resetProfile.dialog.description
* resetProfile.dialog.button.label
* resetProfile.title
* resetProfile.button.label2

Used by:

* Reset Profile dialog: http://mxr.mozilla.org/mozilla-central/source/toolkit/content/resetProfile.xul
* Reset Profile progress window: http://mxr.mozilla.org/mozilla-central/source/toolkit/content/resetProfileProgress.xul
* about:support: http://mxr.mozilla.org/mozilla-central/source/toolkit/content/aboutSupport.xhtml
Points: --- → 3
Summary: Update the Reset Firefox dialog and strings to reflect improved copy → Update all Reset Firefox strings and relevant UI to reflect improved copy
(Reporter)

Updated

3 years ago
Flags: qe-verify? → qe-verify+

Comment 3

3 years ago
I'm working on getting the new copy nailed down. I put together this mockup for feedback from Matej and others - http://invis.io/T31DIVVKU . I'll also look into the other things pointed out in comment 2 that are not addressed in this mockup.

Updated

3 years ago
Whiteboard: [fxgrowth]
(Reporter)

Comment 4

3 years ago
Verdi, of the strings I linked to above, these are the ones that either aren't of the form "Reset Firefox" or otherwise maybe aren't straightforward to change.  We'd like to fix this bug soon -- do you think you'll have new copy ready soon?

http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/safeMode.dtd

<!ENTITY resetProfileInstead.label    "You can also Reset &brandShortName; if you want to start fresh.">

<!ENTITY autoSafeModeDescription2.label "&brandShortName; closed unexpectedly while starting. This might be caused by add-ons or other problems. You can try to resolve the problem by resetting &brandShortName; to its default state or troubleshooting in Safe Mode.">

<!ENTITY resetProfileFooter.label       "Everything else will be reset to factory defaults.">

http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/resetProfile.dtd

<!ENTITY resetProfile.dialog.description  "Are you sure you want to reset &brandShortName; to its initial state?">

<!ENTITY resetProfile.title               "Reset &brandShortName; to its default state">
Flags: needinfo?(mverdi)

Comment 5

3 years ago
(In reply to Drew Willcoxon :adw from comment #4)
>   We'd like to fix this bug soon -- do you think you'll have new
> copy ready soon?

Hi Drew,
I'm trying to get everything complete and approved asap - hopefully by the end of the week. I think it may also involve removing some strings and creating new ones. This isn't complete (or approved) but might help illustrate what I mean http://cl.ly/image/2H181N3p1A2U
Flags: needinfo?(mverdi)

Comment 6

3 years ago
Created attachment 8497821 [details]
refresh strings.png

Hi Drew,
Sorry for the delay. I got Madhava's OK on these this afternoon. I've attached a visual guide (I did this to have context for myself).

about:support
http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/resetProfile.dtd
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/aboutSupport.xhtml

- 11 <!ENTITY resetProfile.title               "Reset &brandShortName; to its default state">
+ 11 <!ENTITY resetProfile.title               "Give &brandShortName; a tune up">

- 12 <!ENTITY resetProfile.description         "If you're having major problems which you can't resolve, start fresh with only your essential information.">
+ 12 <!ENTITY resetProfile.description         "No troubleshooting required!">

- 13 <!ENTITY resetProfile.button.label2       "Reset &brandShortName;…">
+ 13 <!ENTITY resetProfile.button.label2       "Refresh &brandShortName;…">

Reset Profile dialog 
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/resetProfile.xul

- 5 <!ENTITY resetProfile.dialog.title        "Reset &brandShortName;">
+ 5 <!ENTITY resetProfile.dialog.title        "Refresh &brandShortName;">

- 6 <!ENTITY resetProfile.dialog.description  "Are you sure you want to reset &brandShortName; to its initial state?">
+ 6 <!ENTITY resetProfile.dialog.description  "Start fresh to fix problems and restore performance. This will:">

- 7 <!ENTITY resetProfile.dialog.items2.label "&brandShortName; will try to preserve your:">

- 8 <!ENTITY resetProfile.dialog.footer.label "&brandShortName; will restart and everything else will be removed.">

+ New Thing 1 <!ENTITY new.thing.1 "Remove your add-ons and customizations
Restore your browser settings to their defaults">

- 9 <!ENTITY resetProfile.dialog.button.label "Reset &brandShortName;">
+ 9 <!ENTITY resetProfile.dialog.button.label "Refresh &brandShortName;">

Reset Profile progress window
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/resetProfileProgress.xul

- 15 <!ENTITY resetProfile.cleaning.description "Please wait while &brandShortName; cleans up your old data…">
+ 15 <!ENTITY resetProfile.cleaning.description "Almost done…">

Safe mode dialog
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/safeMode.dtd
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/safeMode.xul

- 9 <!ENTITY resetProfile.label           "Reset &brandShortName;">
+ 9 <!ENTITY resetProfile.label           "Refresh &brandShortName;">

- 14 <!ENTITY resetProfileInstead.label    "You can also Reset &brandShortName; if you want to start fresh.">
+ 14 <!ENTITY resetProfileInstead.label    "You can also skip troubleshooting and try refreshing &brandShortName;.">

Safe mode dialog (after multiple startup crashes)
- 17 <!ENTITY autoSafeModeDescription2.label "&brandShortName; closed unexpectedly while starting. This might be caused by add-ons or other problems. You can try to resolve the problem by resetting &brandShortName; to its default state or troubleshooting in Safe Mode.">
+ 17 <!ENTITY autoSafeModeDescription2.label "&brandShortName; closed unexpectedly while starting. This might be caused by add-ons or other problems. You can try to resolve the problem by troubleshooting in Safe Mode.">

- 18 <!ENTITY resetProfileFooter.label       "Everything else will be reset to factory defaults.">

- 19 <!ENTITY safeModeInstead.label          "If you don't want this, you can continue in Safe Mode to do your own troubleshooting with your add-ons and custom settings temporarily disabled.">

about:welcomeback
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/aboutSessionRestore.dtd
http://mxr.mozilla.org/mozilla-central/source/browser/components/migration/content/aboutWelcomeBack.xhtml

- 28 <!ENTITY welcomeback.tabtitle       "Welcome Back!">
+ 28 <!ENTITY welcomeback.tabtitle       "Success!">

- 33 <!ENTITY welcomeback.pageTitle      "Welcome Back!">
+ 33 <!ENTITY welcomeback.pageTitle      "Success!">

+ New Thing 2 <!ENTITY new.thing.2 "&brandShortName; is ready to go.">

- 34 <!ENTITY welcomeback.pageInfo       "&brandShortName; successfully reset your profile. Below is a list of windows and tabs you had open; you can restore them or start with a clean slate.">
+ 34 <!ENTITY welcomeback.pageInfo       "Your add-ons and customizations have been removed and your browser settings have been restored to their defaults. If this didn't fix your issue, learn more about what you can do.">

Unused Profile
http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/resetProfile.properties
http://mxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserGlue.js#637

- 11 resetProfile.resetButton.label=Reset %S…
+ 11 resetProfile.resetButton.label=Refresh %S…
Marco: this is no longer blocked (I only partially updated the spreadsheet).

Mark: can you take this bug given that Drew's away?
Flags: needinfo?(mmucci)
Flags: needinfo?(mhammond)
(Assignee)

Updated

3 years ago
Assignee: nobody → mhammond
Flags: needinfo?(mhammond)
Added to IT 35.3
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Flags: needinfo?(mmucci)
Answering Mark's question from IRC: this is just a normal string change, the entities need to change accordingly.

Updated

3 years ago
QA Contact: jbecerra
(Assignee)

Comment 10

3 years ago
Created attachment 8499353 [details] [diff] [review]
0002-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

The requested changes - please see also the following image attachment and notes I'm about to attach.
Attachment #8499353 - Flags: feedback?(MattN+bmo)
(Assignee)

Comment 11

3 years ago
Created attachment 8499355 [details]
all.png

This attachment is multiple screen-shots with the previously attached patch.  Of note:

* The "safe mode" and "reset profile" dialogs both had a list of items that would be reset which is now gone - so I also removed the JS code to populate it.

* The link text "learn more about what you can do." currently goes to https://support.mozilla.org/en-US/products/firefox?as=u&utm_source=inproduct, which is the main support link.  I *guess* it should go to the /fix-problems page under that?  If that's correct we'll need to arrange for a new link to be created that redirects there.  I think this will be the 3rd time I need to ask Gavin how to go about that :)

* I've left the "close" button on about:welcomeback, as otherwise there's no reasonable way for the user to say "don't restore anything" - is that OK?  It also still has the "information" icon rather than the foxaroo(!?) shown in the mockup - if you really want this new animal, please supply the image.
Attachment #8499355 - Flags: feedback?(mverdi)
(Assignee)

Comment 12

3 years ago
Comment on attachment 8499353 [details] [diff] [review]
0002-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

Review of attachment 8499353 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/migration/content/aboutWelcomeBack.xhtml
@@ +52,5 @@
>  
>          <!-- Short Description -->
>          <div id="errorTrailerDesc">
> +          <input id="radioRestoreAll" type="radio" name="restore" checked="checked"/>
> +          <label for="radioRestoreAll">Restore all Windows and Tabs</label>

oops - just remembered I left these strings in the HTML - assume I'll move them to the aboutSessionRestore.dtd :)

Comment 13

3 years ago
(In reply to Mark Hammond [:markh] from comment #11)
> Created attachment 8499355 [details]
> all.png
> 
> This attachment is multiple screen-shots with the previously attached patch.
> Of note:
> * The link text "learn more about what you can do." currently goes to
> https://support.mozilla.org/en-US/products/firefox?as=u&utm_source=inproduct,
> which is the main support link.  I *guess* it should go to the /fix-problems
> page under that?  If that's correct we'll need to arrange for a new link to
> be created that redirects there.  I think this will be the 3rd time I need
> to ask Gavin how to go about that :)
> 

I'll needinfo Joni Savage (the support content manager) about where the link should go. One thing to be sure to do is to not include the locale string in the link. SUMO will send the user to the right version of the article. Instructions on redirects are here: https://support.mozilla.org/en-US/kb/a-guide-to-linking-to-support-articles

> * I've left the "close" button on about:welcomeback, as otherwise there's no
> reasonable way for the user to say "don't restore anything" - is that OK? 

I didn't realize you could do the functionality of the redesigned page separate from the styling (awesome!). In that case, we can remove the close button. If you want to start a brand new session, you select the other radio button, uncheck the tabs and click "let's go." 

And just to clarify - in this design, the default is "Restore all windows & tabs" with the list closed.  

> It also still has the "information" icon rather than the foxaroo(!?) shown
> in the mockup - if you really want this new animal, please supply the image.

Needinfo-ing Michael Maslaney for that...

Fixing a mistake of mine:
Can you remove the "no troubleshooting required" line from about support? I mistakenly left that in.
Flags: needinfo?(mmaslaney)
Flags: needinfo?(jsavage)
Comment on attachment 8499353 [details] [diff] [review]
0002-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

Review of attachment 8499353 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/sessionstore/content/aboutSessionRestore.js
@@ +15,5 @@
> +  // the in-product link.
> +  var anchor = document.getElementById("linkMoreTroubleshooting");
> +  if (anchor) {
> +    let moreURL = Cc["@mozilla.org/toolkit/URLFormatterService;1"]
> +                  .getService(Ci.nsIURLFormatter)

If you have access to Services, you can use Services.urlFormatter. It would be nice if openHelpLink was more accessible so we can use that.

@@ +80,5 @@
>  function restoreSession() {
>    document.getElementById("errorTryAgain").disabled = true;
>  
> +  if (document.getElementById("radioRestoreChoose").checked) {
> +    // remove all unselected tabs from the state before restoring it

So did we decide we want to use this radio button for about:sessionrestore too?

::: toolkit/content/aboutSupport.xhtml
@@ +30,5 @@
>    <body dir="&locale.dir;">
>  
>      <div id="reset-box">
> +      <h3>&refreshProfile.title;</h3>
> +      <p>&refreshProfile.description;</p>

Sounds like we're nuking refreshProfile.description but I think that will make this box seem unusually small.

::: toolkit/content/resetProfile.js
@@ -14,5 @@
>  Cu.import("resource://gre/modules/Services.jsm");
>  Cu.import("resource://gre/modules/ResetProfile.jsm");
>  
> -// based on onImportItemsPageShow from migration.js
> -function populateResetPane(aContainerID) {

Comment on the plan (not on the patch): I still think that users will have different expectations of what will be preserved and will be disappointed when something isn't preserved and they didn't know about that in advance. IE even lists all their things with checkboxes. This change might even scare more people away because they might think "customizations" includes things like bookmarks.

I think we could mitigate this by providing a link to the SUMO article inside resetProfile.xul since it explains what is preserved.

@@ -32,1 @@
>  function onResetProfileLoad() {

Nit: You could nuke this along with references to it.

::: toolkit/content/resetProfileProgress.xul
@@ +16,5 @@
>  
>  <window id="resetProfileProgressDialog"
>          xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
> +        title="&refreshProfile.dialog.title;"
> +        width="300">

Is this to make it wider or narrower? If the answer is wider, will this still allow the window to grow if the string is longer in another locale? If not, I think you want the min-width CSS property.

::: toolkit/locales/en-US/chrome/global/resetProfile.properties
@@ +4,5 @@
>  
>  # LOCALIZATION NOTE: These strings are used for profile reset.
>  
>  # LOCALIZATION NOTE (resetUnusedProfile.message): %S is brandShortName.
>  resetUnusedProfile.message=It looks like you haven't started %S in a while. Do you want to clean it up for a fresh, like-new experience? And by the way, welcome back!

I don't see a screenshot of the unusedProfile notification bar but please make sure that it was updated appropriately and is still working since there aren't automated tests yet (as we need Marionette for desktop).
Attachment #8499353 - Flags: feedback?(MattN+bmo) → feedback+
Let's link to this SUMO article: https://support.mozilla.org/kb/troubleshoot-and-diagnose-firefox-problems. The article might need some updating, but we'll have it ready by then.
Flags: needinfo?(jsavage)
(Assignee)

Updated

3 years ago
Depends on: 1078914
(Assignee)

Comment 16

3 years ago
Created attachment 8500776 [details]
update.png

(In reply to Matthew N. [:MattN] from comment #14)
> Comment on attachment 8499353 [details] [diff] [review]
> 0002-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch
> 
> If you have access to Services, you can use Services.urlFormatter.

Services wasn't imported - but it is importable - so I imported it :)

> It would
> be nice if openHelpLink was more accessible so we can use that.

The patch as it stands just updates the href of the anchor rather than handling the command itself - which seems fine in this context - so I didn't look into using that.

> > +  if (document.getElementById("radioRestoreChoose").checked) {
> > +    // remove all unselected tabs from the state before restoring it
> 
> So did we decide we want to use this radio button for about:sessionrestore
> too?

Oops - no - I've fixed that.

> ::: toolkit/content/aboutSupport.xhtml
> @@ +30,5 @@
> >    <body dir="&locale.dir;">
> >  
> >      <div id="reset-box">
> > +      <h3>&refreshProfile.title;</h3>
> > +      <p>&refreshProfile.description;</p>
> 
> Sounds like we're nuking refreshProfile.description but I think that will
> make this box seem unusually small.

It doesn't actually look too bad to me - see attachment.

> Comment on the plan (not on the patch): I still think that users will have
> different expectations of what will be preserved and will be disappointed
> when something isn't preserved and they didn't know about that in advance.
> IE even lists all their things with checkboxes. This change might even scare
> more people away because they might think "customizations" includes things
> like bookmarks.
> 
> I think we could mitigate this by providing a link to the SUMO article
> inside resetProfile.xul since it explains what is preserved.

needinfo verdi to answer this.

> Nit: You could nuke this along with references to it.

Done.

> Is this to make it wider or narrower? If the answer is wider, will this
> still allow the window to grow if the string is longer in another locale? If
> not, I think you want the min-width CSS property.

Done.

> I don't see a screenshot of the unusedProfile notification bar but please
> make sure that it was updated appropriately and is still working since there
> aren't automated tests yet (as we need Marionette for desktop).

Done - see attachment for the image, and I tested it works (well, to be honest, I tested it displayed the "reset profile" dialog, but I cancelled that!)
Flags: needinfo?(mverdi)
(Assignee)

Comment 17

3 years ago
Created attachment 8500848 [details] [diff] [review]
0004-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

This is the updated patch with comments from verdi and MattN addressed.

Try at https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=96b10cc8e901 - verdi, can you please give those builds a spin and sign-off on the UI?
Attachment #8499353 - Attachment is obsolete: true
Attachment #8500848 - Flags: ui-review?(mverdi)

Comment 18

3 years ago
(In reply to Matthew N. [:MattN] from comment #14)
> 
> Comment on the plan (not on the patch): I still think that users will have
> different expectations of what will be preserved and will be disappointed
> when something isn't preserved and they didn't know about that in advance.
> IE even lists all their things with checkboxes. This change might even scare
> more people away because they might think "customizations" includes things
> like bookmarks.
> 
> I think we could mitigate this by providing a link to the SUMO article
> inside resetProfile.xul since it explains what is preserved.
> 

Hey Matt - I hear you. I'm confident we have that covered in a slightly different way. Most people will encounter this on mozilla.org where we will link to that article below the refresh button. And the people that encounter this is about:support get there almost entirely from the support article.

(In reply to Mark Hammond [:markh] from comment #17)
> verdi, can you please give those builds a spin and sign-off on the UI?

I tested this on Windows 10 because it was handy. Do I need to test on all the other Windows flavors along with Mac and Linux?

The strings are all correct. But after playing with it there is one tiny change I'd love to make if possible. Can you remove "Or" from the label on the second radio button in about:welcomeback? So it would say "Restore only the ones you want" instead of "Or restore only the ones you want". The "or" is really implied and sounds kind of funny. Sorry for not catching that before.

I also came across a few issues with about:welcomeback :
  * The default view has the list of windows and tabs collapsed but the space for them is visible as a blank area. Is it possible to make this space collapse along with the list?
  * We could use some more space between the label on the first radio button and the second radio button so that they are visually distinct as two choices.
  * If you choose to restore only the tabs you want and de-select everything, the "let's go" button gets grayed out. I'm guessing that's because we changed the way this option works. Do we need a new bug for that?
  * Possibly related to the issue above, if you de-select all windows and tabs and then choose the "restore all" radio button the list collapses but the "let's go" button doesn't become active. It seems that doesn't re-select all the windows and tabs.
Flags: needinfo?(mverdi)
(Assignee)

Comment 19

3 years ago
Created attachment 8502149 [details] [diff] [review]
0004-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

(In reply to Verdi [:verdi] from comment #18)
> I tested this on Windows 10 because it was handy. Do I need to test on all
> the other Windows flavors along with Mac and Linux?

I think that's fine for now.

> The strings are all correct. But after playing with it there is one tiny
> change I'd love to make if possible. Can you remove "Or" from the label on
> the second radio button in about:welcomeback? So it would say "Restore only
> the ones you want" instead of "Or restore only the ones you want". The "or"
> is really implied and sounds kind of funny. Sorry for not catching that
> before.

Done:

+<!ENTITY welcomeback2.label.restoreAll  "Restore all Windows and Tabs">
+<!ENTITY welcomeback2.label.restoreSome "Restore only the ones you want">


> I also came across a few issues with about:welcomeback :

about:welcomeback turned into a bit of a can of worms.  In the interests of making sure the string changes land in time, I've removed the radio buttons from this page and we'll add them back in a followup we can uplift (but note the strings for these buttons *are* included here).  So in this patch there are no radio buttons and the list of windows/tabs is always visible.

Note however that the "Cancel" button has still been removed and the behaviour of the "Let's go" button has been fixed (ie, that button is never disabled, and if no items are selected in the tree the button just starts a new session)

>   * If you choose to restore only the tabs you want and de-select
> everything, the "let's go" button gets grayed out. I'm guessing that's
> because we changed the way this option works. Do we need a new bug for that?
>   * Possibly related to the issue above, if you de-select all windows and
> tabs and then choose the "restore all" radio button the list collapses but
> the "let's go" button doesn't become active. It seems that doesn't re-select
> all the windows and tabs.

As above, both of them are fixed here.
Attachment #8500848 - Attachment is obsolete: true
Attachment #8500848 - Flags: ui-review?(mverdi)
Attachment #8502149 - Flags: review?(MattN+bmo)
(In reply to Verdi [:verdi] from comment #18)
> (In reply to Matthew N. [:MattN] from comment #14)
> > 
> > Comment on the plan (not on the patch): I still think that users will have
> > different expectations of what will be preserved and will be disappointed
> > when something isn't preserved and they didn't know about that in advance.
> > IE even lists all their things with checkboxes. This change might even scare
> > more people away because they might think "customizations" includes things
> > like bookmarks.
> > 
> > I think we could mitigate this by providing a link to the SUMO article
> > inside resetProfile.xul since it explains what is preserved.
> > 
> 
> Hey Matt - I hear you. I'm confident we have that covered in a slightly
> different way. Most people will encounter this on mozilla.org where we will
> link to that article below the refresh button. And the people that encounter
> this is about:support get there almost entirely from the support article.

That doesn't help with the following entry points:
* statup crash detection
* welcome back info bar
* help menu (bug 872241)

Those will be encountered without our web properties.
Created attachment 8502218 [details]
Screenshot of about:support box and dialog

(In reply to Mark Hammond [:markh] from comment #16)
> > ::: toolkit/content/aboutSupport.xhtml
> > @@ +30,5 @@
> > >    <body dir="&locale.dir;">
> > >  
> > >      <div id="reset-box">
> > > +      <h3>&refreshProfile.title;</h3>
> > > +      <p>&refreshProfile.description;</p>
> > 
> > Sounds like we're nuking refreshProfile.description but I think that will
> > make this box seem unusually small.
> 
> It doesn't actually look too bad to me - see attachment.

I still think the reset box on about:support is too sparse. Michael, what do you think? This doesn't need to block landing but we may want to put a string back in the box before uplift.

I think a repair-like icon on the right while aligning the button and heading to the left could work. I think the dialog could use an icon too.
Attachment #8502218 - Flags: feedback?(mmaslaney)
Comment on attachment 8502149 [details] [diff] [review]
0004-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

Review of attachment 8502149 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/safeMode.xul
@@ +36,3 @@
>    </vbox>
>  
>    <vbox id ="safeMode">

Nit: Mind fixing this space while you're here? It'll make it easier to search for |id="safeMode"|.

::: toolkit/content/resetProfile.xul
@@ +25,5 @@
>  
>    <script type="application/javascript" src="chrome://global/content/resetProfile.js"/>
>  
> +  <description value="&refreshProfile.dialog.description1;"></description>
> +  <description value="&refreshProfile.dialog.description2;"></description>

I thought it was preferred to have one description per window/dialog and #1 is the one which describes the window. #2 can stay a label as it was labelling the <vbox> which I would prefer was put back (and reverted the associated CSS change). Semantically that makes sense to me.
Attachment #8502149 - Flags: review?(MattN+bmo) → review+
(Assignee)

Comment 23

3 years ago
Created attachment 8502257 [details] [diff] [review]
0004-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch

Addressed review comments, carry forward r=MattN.  I'll defer landing pending feedback from mmaslaney.
Attachment #8502149 - Attachment is obsolete: true
Attachment #8502257 - Flags: review+
(In reply to Mark Hammond [:markh] from comment #23)
> Created attachment 8502257 [details] [diff] [review]
> 0004-Bug-1063702-Update-all-Reset-Firefox-strings-and-rel.patch
> 
> Addressed review comments, carry forward r=MattN.  I'll defer landing
> pending feedback from mmaslaney.

Mark, can you provide a screenshot for review?
Flags: needinfo?(mhammond)

Comment 25

3 years ago
(In reply to Matthew N. [:MattN] (behind on reviews - focused on Loop) from comment #20)
> 
> That doesn't help with the following entry points:
> * statup crash detection
> * welcome back info bar
> * help menu (bug 872241)
> 
> Those will be encountered without our web properties.

The refresh dialog does state what isn't preserved though it doesn't go into the detail that the support article does. I think this if fine for these cases (willing to be convinced otherwise though):
* startup crash - I'm not sure how that would work. You'd get the safe mode dialog, click refresh, then click a web link. I guess we're already in safe mode at this point but opening an article in safe mode when you've explicitly not selected safe mode is kind of weird and you might think the problem is fixed and no action is necessary which could then result in a startup crash on your next session. I don't have a better answer for this one other than the text of the dialog as is should be enough.
* Welcome back info bar - these are people who haven't used Firefox for more than two months. It's very likely that the details of the things we'd be removing won't be of consequence or noticed. They're already not really using Firefox. 
* help menu - Here I think we should probably wait until we fix Bug 1017919 which is the last big thing most people will be concerned about.


(In reply to Matthew N. [:MattN] (behind on reviews - focused on Loop) from comment #21) 
> I still think the reset box on about:support is too sparse. Michael, what do
> you think? This doesn't need to block landing but we may want to put a
> string back in the box before uplift.
> 
> I think a repair-like icon on the right while aligning the button and
> heading to the left could work. I think the dialog could use an icon too.

Matej and worked on the about:support box and agreed to go with that. It's the same wording that we'll use for mozilla.org/firefox/new - http://cl.ly/image/271i2a3F3G0f  

An icon for about:support (and maybe mozilla.org) might not be a bad idea. Let's see what Michael thinks.

Comment 26

3 years ago
(In reply to Mark Hammond [:markh] from comment #19)
> about:welcomeback turned into a bit of a can of worms.  In the interests of
> making sure the string changes land in time, I've removed the radio buttons
> from this page and we'll add them back in a followup we can uplift (but note
> the strings for these buttons *are* included here).  So in this patch there
> are no radio buttons and the list of windows/tabs is always visible.
> 
> Note however that the "Cancel" button has still been removed and the
> behaviour of the "Let's go" button has been fixed (ie, that button is never
> disabled, and if no items are selected in the tree the button just starts a
> new session)
> 
> >   * If you choose to restore only the tabs you want and de-select
> > everything, the "let's go" button gets grayed out. I'm guessing that's
> > because we changed the way this option works. Do we need a new bug for that?
> >   * Possibly related to the issue above, if you de-select all windows and
> > tabs and then choose the "restore all" radio button the list collapses but
> > the "let's go" button doesn't become active. It seems that doesn't re-select
> > all the windows and tabs.
> 
> As above, both of them are fixed here.

That sounds like a great solution. Thanks!
(Assignee)

Comment 27

3 years ago
(In reply to mmaslaney from comment #24)
> Mark, can you provide a screenshot for review?

See the attachment "update.png" - it doesn't show the entire about:support page but does show the entire box in question.
Flags: needinfo?(mhammond)
(Assignee)

Updated

3 years ago
Blocks: 1080934
Comment on attachment 8502218 [details]
Screenshot of about:support box and dialog

I would recommend left-aligning the header and refresh button.

Example: http://cl.ly/image/413T273U1X0v
Attachment #8502218 - Flags: feedback?(mmaslaney) → feedback-
Flags: needinfo?(mmaslaney)
(Assignee)

Comment 29

3 years ago
(In reply to mmaslaney from comment #28)
> Comment on attachment 8502218 [details]
> Screenshot of about:support box and dialog
> 
> I would recommend left-aligning the header and refresh button.
> 
> Example: http://cl.ly/image/413T273U1X0v

OK - I made an additional tweak to aboutSupport.css to do this and got a quick r=unfocused over IRC for that change.

I'm landing this now in the interests of ensuring it makes the merge - we can make other visual tweaks in followups.

https://hg.mozilla.org/integration/fx-team/rev/38ce31cc9334
https://hg.mozilla.org/mozilla-central/rev/38ce31cc9334
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35

Updated

3 years ago
Blocks: 1087854
Attachment #8499355 - Flags: feedback?(mverdi)
I used Firefox 35 beta 1 to verify this bug and found a few problems:
1) I was unable to make the Unused Profile infobar appear (from first attachment), the messages saying 'Firefox closed unexpectedly while starting...' and Welcome Back! message from Restore Session (only 'Well this is embarrassing'). 
2) For the about:welcomeback page I can only see Let`s go! button (from attachments I see another Close button). 
3) If I open FF with a new profile and Refresh Firefox twice in a row (go through the whole process of Refresh then Refresh again), Firefox will not start, will just quit (If I start firefox with profile manager I can see two default profiles).

Can you provide guidance/explanations for the above?
Flags: needinfo?(mhammond)
(Assignee)

Comment 32

3 years ago
Sorry for the delay here.

(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #31)
> I used Firefox 35 beta 1 to verify this bug and found a few problems:
> 1) I was unable to make the Unused Profile infobar appear (from first
> attachment), the messages saying 'Firefox closed unexpectedly while
> starting...' and Welcome Back! message from Restore Session (only 'Well this
> is embarrassing').

I'm afraid I don't know what could have caused this.  I believe that setting the last-modified time on parent.lock in the profile directory to more than 60 days prior to "now" should trigger that.  Crash reports for the crash might also be helpful.

> 2) For the about:welcomeback page I can only see Let`s go! button (from
> attachments I see another Close button).

IIRC, the "Close" button is only there after the refresh completes, not from a "normal" session restore.

> 3) If I open FF with a new profile and Refresh Firefox twice in a row (go
> through the whole process of Refresh then Refresh again), Firefox will not
> start, will just quit (If I start firefox with profile manager I can see two
> default profiles).

That sounds bad, so STR for that in a new bug sounds the right thing.
Flags: needinfo?(mhammond)
(Assignee)

Comment 33

3 years ago
(In reply to Mark Hammond [:markh] from comment #32)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #31)
> > I used Firefox 35 beta 1 to verify this bug and found a few problems:
> > 1) I was unable to make the Unused Profile infobar appear (from first
> > attachment), the messages saying 'Firefox closed unexpectedly while
> > starting...' and Welcome Back! message from Restore Session (only 'Well this
> > is embarrassing').

I was just working on something related and saw a number of similar issues when re-testing a profile reset.  In particular, I did see the old profiles not be deleted, a startup crash and firefox refusing to shut down.  I'm testing nightly on a VM so the issues may or may not be related, so please CC me on any bugs you open (and I'll CC you on any I open, but I'm not sure when I'll get enough into to do so)
(In reply to Mark Hammond [:markh] from comment #32)
> Sorry for the delay here.
> 
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #31)
> > I used Firefox 35 beta 1 to verify this bug and found a few problems:
> > 1) I was unable to make the Unused Profile infobar appear (from first
> > attachment), the messages saying 'Firefox closed unexpectedly while
> > starting...' and Welcome Back! message from Restore Session (only 'Well this
> > is embarrassing').
> 
> I'm afraid I don't know what could have caused this. I believe that setting
> the last-modified time on parent.lock in the profile directory to more than
> 60 days prior to "now" should trigger that. Crash reports for the crash
> might also be helpful.

I tried to modify the last-modified time for parent.lock file from the profile but the infobar still does not show. Regarding 'Welcome back!' message I was wrong about that, it has been replaced with 'Success!' message, the only issue here are that the button 'Close' and the two radio buttons are not available.

'Also for the other one: 'Firefox closed unexpectedly while starting...' I still can`t get that message, maybe I`m not doing something right in order to trigger that.

> > 2) For the about:welcomeback page I can only see Let`s go! button (from
> > attachments I see another Close button).
> 
> IIRC, the "Close" button is only there after the refresh completes, not from
> a "normal" session restore.

I refreshed Firefox and 'Close' button is not there only 'Let`s go!'. 
I do get 'Restore' and 'Close' buttons if I refresh Firefox from 'Restart with Add-ons Disabled...' option. But the buttons are on the page that says 'Well, this is embarrassing' (Same restore session page that appears after I crash Firefox using add-on). No crash reports are recorded.

> > 3) If I open FF with a new profile and Refresh Firefox twice in a row (go
> > through the whole process of Refresh then Refresh again), Firefox will not
> > start, will just quit (If I start firefox with profile manager I can see two
> > default profiles).
> 
> That sounds bad, so STR for that in a new bug sounds the right thing.

Logged bug 1114565 on that.

If you think that any of the above are issues please let me know so I can go ahead and log bugs.
Flags: needinfo?(mhammond)
(Assignee)

Comment 35

3 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #34)
> Logged bug 1114565 on that.
> 
> If you think that any of the above are issues please let me know so I can go
> ahead and log bugs.

I think bug 1114565 captures this, thanks.
Flags: needinfo?(mhammond)
(In reply to Mark Hammond [:markh] from comment #35)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #34)
> > Logged bug 1114565 on that.
> > 
> > If you think that any of the above are issues please let me know so I can go
> > ahead and log bugs.
> 
> I think bug 1114565 captures this, thanks.

That been said I will go ahead and close this bug as verified fixed.
Status: RESOLVED → VERIFIED
Depends on: 1245139
You need to log in before you can comment on or make changes to this bug.