Closed Bug 1063758 Opened 6 years ago Closed 4 years ago

fxpay: show prices in localized currency for products

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P3)

Avenir
x86
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kumar, Unassigned)

References

Details

Detecting a user's mobile network in third party apps is hard but as a first step let's allow a manual price display. Something like this:

fxpay.getPrice(pricePoint, currency)

where pricePoint is what getProducts() already returns and currency is an ISO string like 'USD'. This would be a simple wrapper around our price API: http://firefox-marketplace-api.readthedocs.org/en/latest/topics/payment.html#price-tiers

This may be more convenient as an argument to getProducts like:

fxpay.getProducts({currencies: ['USD', 'EUR', 'BRL', ...]})
Priority: -- → P3
Duplicate of this bug: 1067927
Based on the recently announced future plans for the Marketplace to remove payments, closing these bugs.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.