The default bug view has changed. See this FAQ.

NSS Fails to build under ARM Linux

RESOLVED FIXED in 3.3.2

Status

NSS
Build
P2
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Mark Crichton, Assigned: Wan-Teh Chang)

Tracking

3.3.2
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla's NSS Build setup fails to recognize an OS_TEST of "armv4l".  Since 
there is no explicit test for it in Linux.mk, it will default to x86.

And, trust me, it's quite entertaining to watch arm-linux-as munch on x86 
code...

Simple fix is to add the following lines in the coreconf/Linux.mk file:

ifeq ($(OS_TEST),armv4l)
        OS_REL_CFLAGS   = -DLINUX1_2 -D_XOPEN_SOURCE
        CPU_ARCH        = armv4l

However, since you can have different ARM types (forst 2 are version, last for 
endian IIRC), there should be a smarter test.  However, since I think only 
recent ARMs can really chew Mozilla, armv4l might be best (it represents most 
Strongarms...dunno about the new XScale.  My ARM knowledge isn't great).
(Assignee)

Comment 1

16 years ago
Thanks for the bug report.  NSS has never been compiled
on Linux/arm.  I will attach a patch for you to try.
(This patch is copied from the old NSPR build system.)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

16 years ago
Created attachment 54816 [details] [diff] [review]
Proposed patch.
(Reporter)

Comment 3

16 years ago
Builds here.

Can't do a running test.  There appears to be some other possible bugs floating 
around somewhere.
(Assignee)

Comment 4

16 years ago
The patch has been checked in on the tip and
the NSS_3_3_BRANCH.  The NSS_CLIENT_TAG has
been moved.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → 3.3.2
You need to log in before you can comment on or make changes to this bug.