If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email][APZ][v2.1] Email app outer vertical scrolling broken by nested horizontally scrollable iframe; all vertical scrolling translated to horizontal scrolling, overscroll logic triggers

RESOLVED DUPLICATE of bug 1062437

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1062437
3 years ago
3 years ago

People

(Reporter: WasiemH, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-Exploratory], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8485229 [details]
flame2.1logcat.txt

Description:
When opening up an email message and clicking on the show external images link, the user is unable to scroll up and down in the message.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140905000202
2) Tap on the email app and open up a inbox message.
3) Click on the show external messages link.
4) Attempt to scroll up or down in the message.

  
Actual:  Clicking on the show external images link in an email prevents user from scrolling up or down the message.

Expected: Clicking on the show external images link in an email allows user to still scroll up or down the message.


Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
  
Repro frequency: 100%

See attached: logcat, video - http://youtu.be/GNYHSsGe5QE
(Reporter)

Comment 1

3 years ago
The issue occurs in Flame 2.2 (319mb), Flame 2.1 (512mb), Open_C 2.2, Open_C 2.1

Clicking on the show external images link in an email prevents user from scrolling up or down the message.

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C Master
Build ID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (512mb)
Build ID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Issue does not occur on Flame 2.0 and Open C 2.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140905000204
Gaia: 4627014cc5c5eeec894183866d4c57291302f8b8
Gecko: 2fae20afe1fa
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140905000204
Gaia: 4627014cc5c5eeec894183866d4c57291302f8b8
Gecko: 2fae20afe1fa
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
I reproduced on an aurora/2.1 flame just now, build 20140907160203

To summarize what's happening:
- The email app's logic isn't working as intended when "display external images" is hit.  When we display the images we are supposed to recompute all of our iframe/etc. sizings so that the iframe is not internally scrollable.  We listen for events and everything.  It's not working, so =>

- The iframe is ending up scrollable because the root "html" element is ending up with:
  - clientWidth: 300
  - scrollWidth: 373
  - clientHeight: 985
  - scrollHeight: 985

- If you initiate a drag/scroll gesture outside of the area of the iframe, nothing happens.  Vertical/horizontal/whatever up in the envelope area results in nothing scrolling at all.

- Initiating a drag/scroll gesture over the iframe always results in interpretation as a horizontal drag.  Even if I'm dragging nearly perfectly vertically, it's getting interpreted as a horizontal scroll, usually resulting in the uniform overscroll effect.

- LayerManager tree coming in a sec as an attachment.


Email things that will be spun off to other bugs/investigations, but probably not until tomorrow:
- Whatever's going on with us not properly resizing the iframe needs to be investigated and fixed, although arguably that bug is much more survivable than the APZ bug.
- When trying to reproduce for the "Google+ team email" I'm experiencing problems where I can see the body when it's first downloaded but then it's like our database state is getting corrupted or something, because on next load getBody seems to be returning null.  Which should absolutely not be happening.
Component: Gaia::E-Mail → Panning and Zooming
Product: Firefox OS → Core
Summary: [E-Mail] Clicking on the show external images link in an email prevents user from scrolling up or down the message → [email][APZ][v2.1] Email app outer vertical scrolling broken by nested horizontally scrollable iframe; all vertical scrolling translated to horizontal scrolling, overscroll logic triggers
Created attachment 8485575 [details]
layer tree dump
It sounds like this is the same issue as bug 1062437 which was fixed recently.
Marking as a dependency for now, but it should be duped if builds with that fix don't manifest this issue any more.
Depends on: 1062437
Seems like this issue has been fixed.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062437
I think I've just seen a much more minor version of this on today's master nightly.  Minor in the sense that I'm sure I got it to happen, but I was able to get things back to normal by pinch-zooming to change scale levels or maybe some extreme finger movements to break out of an axis-lock or something.  I'm suspecting a weird interaction between email's pinch-zoom logic and a scroll/pan gesture or whatnot.  I'm not sure there's any action to be taken at this time, but we should be on the lookout for this happening more.
You need to log in before you can comment on or make changes to this bug.