link attribute "title" displays very wrong on mouseover when there are lengthy "title" entries

VERIFIED DUPLICATE of bug 45375

Status

SeaMonkey
UI Design
--
major
VERIFIED DUPLICATE of bug 45375
17 years ago
10 years ago

People

(Reporter: Shayon Mukerjee, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011019
BuildID:    2001101909

On certain sites, such as tomshardware.com which uses a lengthy title attribute
on its links, when you mouse over the link, the text that should display cleanly
in a yellow window instead sprawls all over the place (off-screen in this case),
and shows characters it shouldn't.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.tomshardware.com
2. Mouse over the first article link (currently "The Storage Champions: ATA/100
IDE RAID Controllers From AMI, HighPoint And Promise")
3. Note the yellow box which appears, and will more than likely scroll offscreen
showing characters which clearly should not display.

Expected Results:  I imagine there should be a standard way that lengthy TITLE
attributes are word-wrapped so that they are still a usable feature when viewed
in Mozilla.  Perhaps a line width should be set, and Mozilla should pop up with
a yellow box instead of simply one long line, which will invariably scroll
offscreen, such as in this example.

The HTML that causes this is, in my example, as follows:

<A HREF="/storage/01q4/011023/index.html" TITLE="October 23, 2001 - The Storage
Champions: ATA/100 IDE RAID Controllers From AMI, HighPoint And Promise
&#10;&#13;&#10;&#13;   After looking at the RAID abilities of Windows 2000, it's
time to compare hardware RAID controllers at more than $150 for IDE. Currently
there are three popular manufacturers for these types of controllers: Ami/LSI
Logic, HighPoint and Promise. All of them have similar features, but we take a
look at the differences" TARGET="_top">The Storage Champions: ATA/100 IDE RAID
Controllers From AMI, HighPoint And Promise</A>

Note the lengthy TITLE, and also the alternate characters it employs.
Marking as dupe of bug 45375. Reporter: If you disagree, please reopen this bug.

-> XP Apps: GUI Features, for parity with dupe

*** This bug has been marked as a duplicate of 45375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Layout → XP Apps: GUI Features
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.