Closed Bug 1063820 Opened 5 years ago Closed 5 years ago

Master Password should be deprecated for the Firefox Account/Sync password

Categories

(Firefox :: Untriaged, defect)

31 Branch
x86
macOS
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 1013064

People

(Reporter: patrick.seiter, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

https://support.mozilla.org/en-US/kb/how-to-update-to-the-new-firefox-sync


Actual results:

https://support.mozilla.org/en-US/kb/why-cant-i-sync-my-passwords


Expected results:

Alright, there is absolutely no way that I'm going to update my browsers to the new sync system so long as it does not sync passwords with a master password set. This is core functionality that I use every day.

So here is my suggestion to fix this issue: replace the master password prompts with Firefox Account password prompts. If I am understanding this page correctly:

https://github.com/mozilla/fxa-auth-server/wiki/onepw-protocol

When the passwords are unencrypted from Sync, simply re-encrypt them using Firefox Account information, so that whenever the master password prompt is displayed, it would instead be a "Firefox Account" prompt for login.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013064
OK. That's fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.