Right click > "Close Tab" closes wrong tab, or hides other tabs

RESOLVED DUPLICATE of bug 107848

Status

--
minor
RESOLVED DUPLICATE of bug 107848
17 years ago
5 years ago

People

(Reporter: down8, Assigned: hyatt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
BiuldID: 2001101803
OS: Win2K Server

Occasionally when rightclicking on a tab [a most awesome addition by the way],
and choosing: "Close Tab", it will close the wrong tab, or even just hide the
tabs [and leaving the tab that was supposed to close open], so that you can not
switch to other open tabs. If you do a Ctrl+T and open a new tab, you can then
see the other tabs again.

This happens pretty randomly, but it's quite a pain when a tab you wanted open
gets closed. It actually happened while I was working on submitting this bug. My
guess would be that it sometimes confuses 'Close Tab' with 'Close Other Tabs' -
but I ain't no programmer. :^)

Comment 1

17 years ago
yup, I've seen this behavior too.. as well as my own in bug 102464 and this
behavior here is really close to bug 106447.

Comment 2

17 years ago
I dont think its duping bug 106385 because I just had that behavior happen in
2001-10-24-03 W2K, its not duplicating.. but closing of wrong tabs when right
clickin on context menu as described here and bug 102464. 

Comment 3

17 years ago
but closing of wrong tabs when right clickin on context menu as described here
and bug 102464 is similar but didn't include the following behavior.  I tried
closing the second tab->'other tabs' closed 1st and third tab.. then Ctrl-T the
first tab came back, the second one (before 'close other tabs') that I am on is
back as the second tab.. and I have the third tab being a new tab window..  

-Its hiding tabs now instead of closing them.

Comment 4

17 years ago
this behavior happens when there is 3 tabs open.. 2 tabs open has different
behavior.

Comment 5

17 years ago
note to self: hiding tabs is not implemented prior to this posted comment, but a
checkin is in 2001-10-25. 

so as in 106447, it appears there is a different behavior than I had described
here 'Ctrl-T' vs 'Open in new Tab' and '2 tabs' vs '3+ tabs'.  so these two bugs
maybe duplicates the more I try to figure out the cause.

any testing help would be appreciated here, thank you.

-dennis

Comment 6

17 years ago
I saw this, but only after I had attempted to install MultiZilla, found that it
doesn't work in recent nightlies, and then went on trying to use Mozilla's
normal tabs. When I installed the Mozilla nightly from scratch without involving
MultiZilla, I haven't seen this at all. So could this be some sort of conflict
with MultiZilla?

Comment 7

17 years ago
Can anybody still reproduce this ? Fix for Bug 107276 could have fixed this also.

Comment 8

17 years ago
I can't reproduce it anymore on Linux and Win98. Fixed?

Updated

17 years ago
Whiteboard: possible dup of 107276

Comment 9

17 years ago
is this a dup of bug 107848 ?

Comment 10

17 years ago
*** Bug 112390 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 110855 has been marked as a duplicate of this bug. ***
fixed 2001112009 Steven Groginsky
dupping...

*** This bug has been marked as a duplicate of 107848 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: possible dup of 107276
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.