[Camera] Using edge gesture during video recording causes device to have low performance

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: SalvadorR, Unassigned)

Tracking

({perf, regression})

unspecified
ARM
Gonk (Firefox OS)
perf, regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [2.1-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8485313 [details]
logcat_20140905_1531.txt

Description:
When user attempts to use edge gesture while recording a video, the performance of the device will decrease.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140905000202
2) Open a edge gesture supported app
3) Go back to homescreen and open Camera app
4) Record a video and use edge gesture to switch back to the first app
5) Observe performance of device

Actual:
Performance of device greatly decreases
  
Expected: 
Transition to app is smooth and performs correctly 
  
Environmental Variables:
Device: Flame 2.1 (319 mb)
BuildID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Notes: Occasionally during the edge swipe, the camera will remain recording while the screen is going through edge gesture.
  
Repro frequency: (2/3)
See attached: (Video clip, Logcat)
http://youtu.be/EfwfOrwIr80
(Reporter)

Comment 1

4 years ago
This issue occurs on Flame 2.1 (319 mb) and Flame 2.2 (319mb)

Actual:
Performance of device greatly decreases

Flame 2.2 (319 mb)

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-------------------------------------------------------------------------------

This issue does NOT occur on Flame 2.1 (512 mb), Flame 2.0 (319mb), Flame 1.4 (319mb), Flame 1.3 Base Image (v123), Open C 2.2, Open C 2.1, Open C 2.0 and Open C 1.4

Expected: 
Transition to app is smooth and performs correctly

Flame 2.1 (512 mb)

Environmental Variables:
Device: Flame 2.1 (512mb)
Build ID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0  (319 mb)

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140905000204
Gaia: 4627014cc5c5eeec894183866d4c57291302f8b8
Gecko: 2fae20afe1fa
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4 (319mb)
BuildID: 20140905000203
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: cbb6d7ad8641
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Flame 1.3 

Device: Flame 1.3
Build ID: 20140627162151
Gaia: 5c43d012a9351e8aaeacda0b87b0886b7f67d33d
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Open C 2.2

Environmental Variables:
Device: Open_C Master
Build ID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2 (2.1)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140905000204
Gaia: 4627014cc5c5eeec894183866d4c57291302f8b8
Gecko: 2fae20afe1fa
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 1.4 

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140904063007
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: acb69ef9f3e4
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Performing the edge gesture while in the camera is very sluggish. I don't think this is severe enough to block on though since it the edge gesture is working.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: perf, regression
Does this reproduce when the camera app has the viewfinder active, but recording isn't active?
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
The performance when swiping between camera app that's simply on camcorder viewfinder (not recording) and another app such as Marketplace is smooth. You can definitely tell the difference between when it's recording and not.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
I was using 319mb flame on the following build

Device: Flame 2.2 KK
BuildID: 20140912061053
Gaia: b72909030e214175144342f7e5df7e88a2b52fd4
Gecko: 59d4326311e0
Version: 35.0a1 (2.2)
Firmware: v165
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 6

3 years ago
[Tracking Requested - why for this release]:
tracking-b2g: --- → backlog

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
status-firefox45: --- → affected
Priority: -- → P3

Comment 7

3 years ago
clearing status-firefox45 status flag.
status-firefox45: affected → ---

Updated

3 years ago
tracking-b2g: backlog → ---

Comment 8

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.