Restore edit mode's [x] icon

RESOLVED FIXED in Firefox 35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lucasr, Assigned: lucasr)

Tracking

unspecified
Firefox 35
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Regression from bug 1054916 I think.
Assignee

Updated

5 years ago
Attachment #8487212 - Flags: review?(michael.l.comella)
Comment on attachment 8487212 [details] [diff] [review]
Restore edit mode's [x] icons (r=mcomella)

Review of attachment 8487212 [details] [diff] [review]:
-----------------------------------------------------------------

What did you do to modify the image files?
Assignee

Comment 3

5 years ago
(In reply to Michael Comella (:mcomella) from comment #2)
> Comment on attachment 8487212 [details] [diff] [review]
> Restore edit mode's [x] icons (r=mcomella)
> 
> Review of attachment 8487212 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> What did you do to modify the image files?

Simply re-committed the original images I used in bug 1010740.
Comment on attachment 8487212 [details] [diff] [review]
Restore edit mode's [x] icons (r=mcomella)

Review of attachment 8487212 [details] [diff] [review]:
-----------------------------------------------------------------

wfm, but I'm afraid of the loss of the optimizations we were supposed to make in bug 1054916.
Attachment #8487212 - Flags: review?(michael.l.comella) → review+
Chris, is there anything to be done here to restore the optimizations from bug 1054916?
Flags: needinfo?(chriskitching)
(In reply to Michael Comella (:mcomella) from comment #5)
> Chris, is there anything to be done here to restore the optimizations from
> bug 1054916?

Of course, just run `trimage` on all the PNGs you touched.

It's in the AUR.

Usage:

`trimage -f something.png`

Simplez!
Flags: needinfo?(chriskitching)
Oh. Right. I should read context. That caused the bug.... Wat.

Sec.
So these images look identical to the original ones. However, trimage uses indexed PNGs with an alpha channel, something which seems to be poorly supported.
Perhaps Android is incapable of loading such PNGs?

I'm pretty unclear how two images that are ostensibly identical can look different. Is the symptom that the image fails to load at all, or that it loads broken in some way?
Flags: needinfo?(lucasr.at.mozilla)
Assignee

Comment 9

5 years ago
Context: I changed the icons in bug 1010740 but bug 1054916 landed in m-c after it. The patch in bug 1054916 was applied on the old icons and overrode the images I had added. The main evidence of this is that the xxhdpi version of the new icon (from bug 1010740) wasn't affected because it didn't exist by the time Chris generated the patch for bug 1054916.

Anyway, I did run trimage on the images I restored here. They're all properly optimized.
Flags: needinfo?(lucasr.at.mozilla)
Oh, that's great news. Not a problem with trimage , just an annoying race condition. Sorry for the confusion.
Go forth and land it! :P
https://hg.mozilla.org/mozilla-central/rev/5cfb23b1d315
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
You need to log in before you can comment on or make changes to this bug.