Closed Bug 1063949 Opened 6 years ago Closed 6 years ago

Browser loses focus with Flashblock Addon installed

Categories

(Core :: Plug-ins, defect)

34 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1063978

People

(Reporter: jmjjeffery, Unassigned)

Details

(Keywords: regression)

With the landing of bug https://bugzilla.mozilla.org/show_bug.cgi?id=768802 Flashblock is not working right.

On CNN is where I've noticed it most, navigation to any story will switch to that story, then it appears that Flashblock will try to do the blocking, but it fails and the browser loses 'focus', requiring a click in main-body to scroll and read the story or navigate 'back' to main page, where at times it will will 'lose focus'.



I'm guessing the bug noted above is the culprit as this regression range shows:

Good: 20140830032413 5fd6428ae179 <- cset prior that works as expected.
Bad : 20140830092614 983cf2175495 <- cset that the bug above landed

Tested with new profile as well with only Flashblock installed and the browser still is losing focus when navigating CNN or other sites with embedded Flash content.  Only disabling Flashblock seems to correct the loss of focus.

STR:
Start new Profile
Download Flashblock here: http://1drv.ms/1q0dV5V  this is a patched version to work-around issues with Flashblock caused by bug 1050049.

Tested on Win7 x64.
Also using latest release Flash 14.0.0.179
Any chance https://bugzilla.mozilla.org/show_bug.cgi?id=1061257 could help here ?

I'm not a coder so have no idea how to dig deeper.
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

I'm able to reproduce it.

STR:
1) Install Flashblock 1.5.17 from http://1drv.ms/1q0dV5V
2) Go to http://webhtb.sourceforge.net/video_demo.html
NB: Resize your browser window to have the vertical scrollbar, if need be.
3) After the page has loaded, try to scroll with mouse.

Result: impossible to scroll, the user needs to click on the body document to have the focus.

The issue appears each time the Flash plugin is called by Firefox.
If plugincontainer.exe and FlashPlayerPlugin_14_0_0_179.exe are already running, the issue is not present and the user can scroll.
Component: General → Plug-ins
Flags: needinfo?(aklotz)
Product: Firefox → Core
I can reproduce the same problem without Flashblock. Refer to Bug 1063978 .
See Also: → 1063978
Can you confirm this is a dupe of 1063978 i.e. the problem also occurs without Flashblock?
Flags: needinfo?(jmjeffery)
(In reply to Gian-Carlo Pascutto [:gcp] from comment #5)
> Can you confirm this is a dupe of 1063978 i.e. the problem also occurs
> without Flashblock?

yes, using the STR in bug 1063978 the problem occurs of the browser losing focus on start-tup of flash player.
Flags: needinfo?(jmjeffery)
Flags: needinfo?(aklotz)
I'm going to dupe this then on the assumption the other bug is the root cause, though we might want to verify these STR after the other bug is fixed, just in case 1063978 hides any other bugs with Flashblock interaction.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063978
Possibly fixed with update to Flash: 15.0.0.152
You need to log in before you can comment on or make changes to this bug.