Webpage can force color with CSS !important despite "Use my colors only" pref

RESOLVED DUPLICATE of bug 43220

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 43220
17 years ago
17 years ago

People

(Reporter: BenB, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Reproduction:
1. Activate "Use my colors only" pref
2. Visit a page with a link with CSS "color: black !important"

Actual result:
Link is black

Expected result:
Link is blue (user pref)

Additional comments:
I leave it up to someone else to produce a reduced testcase :).
Here's some relevant code from the page I saw:

<font face="Arial" size="2" color="Black">
<a href="view.cfm?view=..."
 style="text-decoration: none !important; color: black !important;">
Imri Vzone 19er
</font></a>

<http://www.brinkmann.de/view.cfm?view=Computer%20%2B%20Zubeh%F6r%7C19er%20%2D%2021er%20%5BMonitore%20%2F%20Displays%5D%7Cnone>
According to section 6.4.2 of the CSS2 spec
(http://www.w3.org/TR/REC-CSS2/cascade.html#important-rules), this is actually
CSS1-conformant behavior. User "!important" rules only started taking precedence
over author "!important" rules in CSS2.
(Reporter)

Comment 2

17 years ago
But we are supposed to follow the CSS2 rules.
Fixed (tested on that page in today's build) by the checkin for bug 43220
("[CASCADE]author !important rules override user !important rules in user.css")

*** This bug has been marked as a duplicate of 43220 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.