Date of server's mail reception is replaced by date of client's mail reception

RESOLVED DUPLICATE of bug 266434

Status

RESOLVED DUPLICATE of bug 266434
4 years ago
4 years ago

People

(Reporter: fruchtfliege, Unassigned)

Tracking

31 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36

Steps to reproduce:

I added a mail account with lots of old e-mails and fetched them.


Actual results:

Everything worked fine except that for some mails. Even though they have been received on the server-side months ago, a handful of mails get shown with the current date as reception in the client. 

Example - the following was received on the 21st of August. Yet it is shown as being from the 7th of September. See relevant headers of the mail below (first line was added by TB, better readable:  http://pastebin.com/T9pafzL4):

From - Sun Sep  7 08:53:02 2014
X-Account-Key: account1
X-UIDL: xxxxxx-yyyyyy-zzzz
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Return-Path: events@pokerstars.eu
Received: from mail35.pokerstars.eu ([77.87.180.205]) by mx-ha.gmx.net
 (mxgmx012) with ESMTP (Nemesis) id xxxxxx-yyyyyy-zzzz for
 <my@email>; Thu, 21 Aug 2014 18:24:40 +0200
Received: from 192.168.1.35 (sigma12 [192.168.1.12])
	by mail35.pokerstars.eu (mailer) with SMTP id 54xxxxx2
	for <my@email>; Thu, 21 Aug 2014 12:24:40 -0400 (EDT)
To: my@email
X-PS-ID: cmdflgjrw45j
Subject:Win a share of $25K in the VIP Club All-in Shootout
From: "Events at PokerStars" <events@pokerstars.eu>
MIME-Version: 1.0


Expected results:

I expect the reception date of the mail to be the 21st of August.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266434
You need to log in before you can comment on or make changes to this bug.