Closed Bug 10641 Opened 21 years ago Closed 21 years ago

Can't open browser from mailnews

Categories

(SeaMonkey :: MailNews: Message Display, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scottputterman, Assigned: davidm)

Details

Clicking on the browser icon in the taskbar or choosing the browser from the
tasks menu does nothing. Currently there's a js error that says:

JavaScript error: topWindowOfType has no properties
URL: file:///D|/raptor/mozilla/dist/WIN32_D.OBJ/bin/chrome/messenger/content/def
ault/messenger.xul LineNo: 60

If this isn't you could you reassing to whoever is doing this.

If there's already a browser, it brings it to the top.
Assignee: hangas → davidm
David, this is your JavaScript.  I seem to remember it is not your problem so

please pass the bug along if it belongs to someone else.
OS: Windows NT → All
Hardware: PC → All
This happens on Mac and Linux as well.
QA Contact: lchiang → nbaca
Status: NEW → ASSIGNED
Actually this is a new bug in the js.
Priority: P3 → P2
Target Milestone: M9
David, is this our bug?
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Paul and I just checked in a fix. Should work ibn 8/3 builds. Also fixed problem
with browser windows not having toolbars.
Status: RESOLVED → VERIFIED
Build 1999080413M9: Win32/NT4, Linux/Redhat 5.2, Mac 8.5.1
Verified Fixed.  Started Mail and used menu item Tasks/Navigator and it launched
the browser. Also used the browser icon in the Taskbar which also launched the
browser.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.