"No module named manifest" with web-platform-tests-update

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: karlt, Assigned: karlt)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Following instructions at 
https://github.com/mozilla/gecko-dev/blob/master/testing/web-platform/README.md#autogenerating-expectation-data

and running the command
  ./mach web-platform-tests-update --no-check-clean wpt.with.mse

yields

git rev-parse --show-cdup
fatal: Not a git repository (or any parent up to mount point /mnt/ssd1)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
{'cwd': u'/mnt/ssd1/karl/moz/dev/testing/web-platform/sync'}

git rev-parse --show-cdup
fatal: Not a git repository (or any parent up to mount point /mnt/ssd1)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
{'cwd': u'/mnt/ssd1/karl/moz/dev/testing/web-platform/sync'}

Traceback (most recent call last):
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/update.py", line 305, in update_metadata
    ignore_existing=ignore_existing)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 49, in update_expected
    manifest = load_test_manifest(test_root, metadata_root)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 31, in load_test_manifest
    do_test_relative_imports(test_root)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 75, in do_test_relative_imports
    import manifest
ImportError: No module named manifest
Error running mach:

    ['web-platform-tests-update', '--no-check-clean', 'wpt.with.mse']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ImportError: No module named manifest

  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/mach_commands.py", line 120, in update_web_platform_tests
    return wpt_updater.run_update(**params)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/mach_commands.py", line 78, in run_update
    update.run_update(**kwargs)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/update.py", line 367, in run_update
    kwargs["run_log"], kwargs["ignore_existing"])
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/update.py", line 305, in update_metadata
    ignore_existing=ignore_existing)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 49, in update_expected
    manifest = load_test_manifest(test_root, metadata_root)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 31, in load_test_manifest
    do_test_relative_imports(test_root)
  File "/mnt/ssd1/karl/moz/dev/testing/web-platform/harness/wptrunner/metadata.py", line 75, in do_test_relative_imports
    import manifest
(Assignee)

Comment 1

4 years ago
Created attachment 8485604 [details] [diff] [review]
distinguish between sync and test paths in metadata.update_expected()
(Assignee)

Updated

4 years ago
Assignee: nobody → karlt
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Blocks: 1064153
(Assignee)

Updated

4 years ago
Blocks: 1064154
(Assignee)

Updated

4 years ago
Attachment #8485604 - Flags: review?(james)
Comment on attachment 8485604 [details] [diff] [review]
distinguish between sync and test paths in metadata.update_expected()

Review of attachment 8485604 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch; it basically looks right, but needs to be fixed upstream, so I adapted it a little and submitted https://critic.hoppipolla.co.uk/r/2533 to make the metadata work without a local repository.
Attachment #8485604 - Flags: review?(james)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1064153
This landed upstream a while ago.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.