Connect with WPS sometimes contains 3 lines

RESOLVED FIXED in 2.1 S5 (26sep)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nefzaoui, Assigned: eragonj)

Tracking

unspecified
2.1 S5 (26sep)
All
Linux

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [p=1])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8485599 [details]
Bug Screenshot 2014-09-08-06-08-26

Sometimes in Wifi section the list item "Connect with WPS" contains 3 lines (as shown in screenshot)
Steps to reproduce:

- Go to Wifi Section
- Go to "Connect with WPS"
- Press the header's button "OK"
(Reporter)

Updated

4 years ago
status-b2g-v2.0: --- → ?
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → affected
(Reporter)

Comment 1

4 years ago
needinfo'ing Ej (Settings' connectivity peer per the modules wiki..)
Flags: needinfo?(ejchen)
Hi Nefzaoui, can you provide more information about your using device ?

Your using branch (Gecko+Gaia) would be helpful to help me understand whether this is a regression or something else.

I assign myself on this bug first and would give it a check later, thanks !
Assignee: nobody → ejchen
Flags: needinfo?(ejchen) → needinfo?(nefzaoui.ahmed)
Created attachment 8489238 [details] [review]
patch on master (2.2)

Arthur, this is a bug regressed from bug 914941 and is a one-line fix, can you help me review this ? thanks !
Attachment #8489238 - Flags: review?(arthur.chen)
This bug is regressed from bug 914941 which was landed after v2.1, so let me update the flag.

And I already tested by QA tool to verify this problem does exist on v2.1 and v2.2.
status-b2g-v2.0: ? → unaffected
status-b2g-v2.1: ? → affected
Flags: needinfo?(nefzaoui.ahmed)
Comment on attachment 8489238 [details] [review]
patch on master (2.2)

LGTM, thanks!
Attachment #8489238 - Flags: review?(arthur.chen) → review+
Comment on attachment 8489238 [details] [review]
patch on master (2.2)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Users would see weird strings on screen.
[Testing completed]: No, this bug was regressed from bug 914941 which we didn't change the Selector when updating. So this is only one-line fix to update the selector.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Attachment #8489238 - Flags: approval-gaia-v2.1?(bbajaj)
Merged into Gaia/master (2.2) first and waiting for 2.1 approval if this patch is needed

https://github.com/mozilla-b2g/gaia/commit/76b9f7dfa83c5eff5a77500c45ae7d5e8eaaf79e
Whiteboard: [p=1]
Target Milestone: --- → 2.1 S5 (26sep)
Comment on attachment 8489238 [details] [review]
patch on master (2.2)

This is a minor bug and if we really want this, I would jump in to merge this patch into needed branches after triage.
Attachment #8489238 - Flags: approval-gaia-v2.1?(bbajaj)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.