bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Titles of frame pages don't show

VERIFIED INVALID

Status

()

Core
Layout: HTML Frames
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: James Mohler, Assigned: Eric Vaughan)

Tracking

({helpwanted})

Trunk
x86
Windows 2000
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
On the pages inside of a frameset, the titles of those page are not shown:

http://www.w3.org/TR/html4/struct/global.html#h-7.4.2

In particular:
"For reasons of accessibility, user agents must always make the content of the
TITLE element available to users (including TITLE elements that occur in
frames). The mechanism for doing so depends on the user agent (e.g., as a
caption, spoken)."
(Reporter)

Updated

17 years ago
Summary: Titles of frame pages do show → Titles of frame pages don't show
->evaughan

cc'ing mpt to request implementation suggestion.
Assignee: pollmann → evaughan
Blocks: 1995
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted

Comment 2

17 years ago
If you specify a title for a frame page, it will display as a tooltip when you
hover over it. This is how we, the user-agent, in this case use the "title"
attribute.

Worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
user agents must always make the content of the
TITLE ***********element************** available

This is not refering to the title attribute, but the title tag.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 4

17 years ago
what's wrong w/ frame info?
(Reporter)

Comment 5

17 years ago
Looks like it is working right now.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
 According to the reporter worksfine for me. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.