Closed Bug 1064249 Opened 6 years ago Closed 6 years ago

[MobileID][2.0] The Mobile ID flow can't be completed with a manually inserted phone number

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

(Whiteboard: ft:Loop [blocking][platform])

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1045581 +++

Device: FireE
Loop version: 08b040a
Build: flame_light-JB.user.master.B-56.Gecko-cc3c2e4.Gaia-8dd303f

1.- Login using Phone Number
2.- Choose "add your phone number"
3.- Don't put any prefix, and fill the number field.
4.- Push "share" button.

ACTUAL RESULT
Loop remains permanently trying to connect.

EXPECTED RESULT
Some message should be displayed. (or not be able to leave the field blank)
This one wasn't properly fixed on 2.0. We needed a different patch for that branch :(.
Assignee: nobody → ferjmoreno
Attached patch v1 (obsolete) — Splinter Review
Sam, this is the same fix as for bug 1045581 but since bug 1020859 isn't on v2.0 we have no access to the raw HAWK request object and we can only play with the response text. Fortunately, the response text is enough to fix this issue without requiring bug 1020859 to be uplifted to v2.0.

My apologies for not noticing this before.
Attachment #8485740 - Flags: review?(spenrose)
Comment on attachment 8485740 [details] [diff] [review]
v1

Thanks Fernando. Could you take the comment about 204 out? Are you sure this patch will apply cleanly to the 2.0 tree? It looks like you created it on top of 585c5de526d2 instead of 5af3884cea83 .
Attachment #8485740 - Flags: review?(spenrose) → review+
Attached patch v1Splinter Review
Thanks Sam!

Yes, it applies on top of the latest v2.0 [1] (e2091483dd6a)

[1] https://hg.mozilla.org/releases/mozilla-b2g32_v2_0

[Approval Request Comment]
This is a leftover from bug 1045581, so the same comment from https://bugzilla.mozilla.org/show_bug.cgi?id=1045581#c13 applies here.
Attachment #8485740 - Attachment is obsolete: true
Attachment #8485906 - Flags: approval-mozilla-b2g32?
[Blocking Requested - why for this release]: Bug 1045581 didn't properly fix this bug, this needs uplifting.

Fernando can you please give a strong reason why this patch needs to get approval.
blocking-b2g: --- → 2.0?
Flags: needinfo?(ferjmoreno)
blocking-b2g: 2.0? → 2.0+
Attachment #8485906 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+
I(In reply to Martijn Wargers [:mwargers] (QA) from comment #6)
> [Blocking Requested - why for this release]: Bug 1045581 didn't properly fix
> this bug, this needs uplifting.
> 
> Fernando can you please give a strong reason why this patch needs to get
> approval.

The reasons were the same as the ones for bug 1045581
Flags: needinfo?(ferjmoreno)
Whiteboard: ft:Loop [blocking][platform] → ft:Loop [blocking][platform][checkin-needed-2.0]
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/5279b33ac908
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: ft:Loop [blocking][platform][checkin-needed-2.0] → ft:Loop [blocking][platform]
Target Milestone: --- → 2.1 S4 (12sep)
Ok, I assume the str were without any SIM in the device, then I can call this bug VERIFIED.
In that case, I can't continue with the "Share" button with leaving the prefix blank.

In case there is already a SIM in the device, then the prefix is already prefilled in the mobile ID dialog.
Status: RESOLVED → VERIFIED
Attached video video
This issue has been verified successfully on Woodduck 2.0
See attachment: Verify_1064249.MP4
Reproducing rate: 0/5

woodduck 2.0 build:
Gaia-Rev        eb015be03823460c5dae8812d7aded9087e0b8a5
Gecko-Rev       e3dc9e5cba07c956e34f03fc0b8fcd2342d57234
Build-ID        20141215050313
Version         32.0
Blocks: Woodduck
You need to log in before you can comment on or make changes to this bug.