Closed Bug 1064288 Opened 5 years ago Closed 5 years ago

Telemetry alerts for CC histograms.

Categories

(Core :: XPCOM, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1061202

People

(Reporter: rvitillo, Unassigned)

Details

Cerberus has detected distribution changes on the 30th of August for the following histograms (see http://vitillo.github.io/cerberus/dashboard/):

CYCLE_COLLECTOR
CYCLE_COLLECTOR_VISITED_REF_COUNTED
CYCLE_COLLECTOR_VISITED_GCED
CYCLE_COLLECTOR_MAX_PAUSE
CYCLE_COLLECTOR_FULL

To me it seems like a possible regression of some kind.
I think this is bug 1061202.
(In reply to Olli Pettay [:smaug] from comment #1)
> I think this is bug 1061202.

Yeah, that would definitely do it.  GHOST_WINDOWS probably also regressed.
(In reply to Andrew McCreight [:mccr8] from comment #3)
> (In reply to Olli Pettay [:smaug] from comment #1)
> > I think this is bug 1061202.
> 
> Yeah, that would definitely do it.  GHOST_WINDOWS probably also regressed.

It did: http://vitillo.github.io/cerberus/dashboard/#2014-08-30GHOST_WINDOWS
So was there a corresponding improvement notification after the fix in bug 1061202 landed (4 days ago)? Or is it too early for that?
Flags: needinfo?(rvitillo)
It's too early to tell, alerts have a one week delay.
Flags: needinfo?(rvitillo)
As discussed on #perf, a manual check of the histograms confirms that the regression has been fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Thanks for filing this.  It is cool that telemetry noticed this.  I need to get around to signing up for the mailing list.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1061202
It's super cool that we caught this.
It's also nice that we already knew what the cause was, otherwise there would have been a lot of head-scratching.
You need to log in before you can comment on or make changes to this bug.