[Camera][SHB] Camera app has a white border while in Task manager view

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Camera
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [shb-enabled][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8485849 [details]
log.txt

Description:
While in Task Manager the Camera app has a white boarder.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140908000204
2) Enable Software Home Button in developer options
3) Open the Camera app
4) Long press on the Home button
  
Actual:
A white boarder appears around the Camera app while in the Task Manager view.
  
Expected:
A black boarder is displayed which is consistent with the Camera app.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
Notes:
Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8485850 [details]
2014-09-08-10-24-52.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

4 years ago
Summary: [Camera][SHB] Camera app has a white boarder while in Task manager view → [Camera][SHB] Camera app has a white border while in Task manager view
It's inconsistent behavior from Video app in card view (task manager).  Not going to nominate to block release, it's a non-functional bug.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
(In reply to Peter Bylenga [:PBylenga] from comment #2)
> It's inconsistent behavior from Video app in card view (task manager).  Not
> going to nominate to block release, it's a non-functional bug.

This bug only occurs when the SHB is enabled?
Whiteboard: [shb-enabled] → [shb-enabled][systemsfe]
(In reply to Gregor Wagner [:gwagner] from comment #3)
> (In reply to Peter Bylenga [:PBylenga] from comment #2)
> > It's inconsistent behavior from Video app in card view (task manager).  Not
> > going to nominate to block release, it's a non-functional bug.
> 
> This bug only occurs when the SHB is enabled?

On Flame yes, Camera gets side borders because it's honoring the aspect ratio and the SHB reduces available height.  Video also does this but Video's borders remain black in card view.
Before we decide not to block, can we confirm that it's a problem with camera app, by finding a regression range?  Because if this turns to be a graphics issue (and it may very well be, given that we're on a non-integer-multiply screen (Flame is 1.5x) we don't want to find out about it being a blocker in two months.
Keywords: regressionwindow-wanted
Swapping regressionwindow-wanted for QA-wanted tag first to do Branch Checks - after which I'll re-add the regression-window tag. (this way we will verify it IS a regression and know where to start looking for the window).
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted → qawanted
QA Contact: ckreinbring
The bug repros on Flame 2.2, Flame 2.1 and Open C 2.2.  However, I had to switch the camera mode to video before the bug would repro.
Actual result:  Long-tappng the software home button while the camera app is running will show a white border on the left and right side of the card.

Flame 2.2
BuildID: 20140909070054
Gaia: 4abb193ddae0f9780ad12ffe5e31772feee3926a
Gecko: 4d1793da0b96
Platform Version: 35.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140909090754
Gaia: d8ca7e1b501ad599512948ef5aa8d4983915316b
Gecko: d0d0a1129710
Platform Version: 34.0a2
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.2
BuildID: 20140909070054
Gaia: 4abb193ddae0f9780ad12ffe5e31772feee3926a
Gecko: 4d1793da0b96
Platform Version: 35.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0.
Actual result: Long-tappng the software home button while the camera app is running will show the camera card rendered with no errors.

BuildID: 20140909100154
Gaia: 59a670d40ad7f5966ec7fafcab0f05009bea97ab
Gecko: 20a65e2619ca
Platform Version: 32.0
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: unaffected → ---
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Josh - Should this be nominated if we're planning to do a window here?
Flags: needinfo?(jmitchell)
[Blocking Requested - why for this release]:

(In reply to Jason Smith [:jsmith] from comment #8)
> Josh - Should this be nominated if we're planning to do a window here?

I was a little uncertain on this -  Typically we would do a window because it WAS a nominated regression, but it does make sense to nominate when a window is required. 

Nomming as it is a regression and the previously discussed points as well
blocking-b2g: --- → 2.1?
Flags: needinfo?(jmitchell)
Sorry for the noise - discussed in IRC, reverting to a non-nom as this is just a minor graphic issue and because this is not a blocker, we do not do regression windows on non-blocking issues (because of the cost in man-hours) so striking that as well.
blocking-b2g: 2.1? → ---
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
Confirmed that this happens on:
- gonk:  v184
- gecko: aurora:c4a4b04c617c
- gaia:  v2.1:778ebac47554e1c4b7e9a952d73e850f58123914

This happens with the Camera app, but not the Video app. I wonder if this is just a simple matter of setting the app background colour.
Flags: needinfo?(dmarcos)
Created attachment 8512548 [details]
2014-10-28-17-59-08.png

Reproduced on today's build, but the white line is horizontal

Gaia-Rev        f520936ab0505717bc0b5e380d1dd77cb39ab45c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f300fefb7842
Build-ID        20141027161202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141027.201213
FW-Date         Mon Oct 27 20:12:22 EDT 2014
Bootloader      L1TC00011880
Created attachment 8512549 [details]
2014-10-28-17-58-05.png

Black line on top and bottom in Camera, before entering task switcher

Comment 14

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.