Setting the style on group box causes mozilla to hang - see testcase

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: wgrinfeld, Assigned: hyatt)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

17 years ago
In case the style width and height is set in this testcase, mozilla will hang 
on reloading the page. Setting height and width without affecting style will 
work OK.
(Reporter)

Comment 1

17 years ago
Created attachment 54855 [details]
used xbl - do not run
(Reporter)

Comment 2

17 years ago
Created attachment 54856 [details]
used css
(Reporter)

Comment 3

17 years ago
Created attachment 54857 [details]
testcase to run
(Reporter)

Comment 4

17 years ago
Created attachment 54858 [details]
run this page rather than above one

Comment 5

17 years ago
Created attachment 54961 [details]
wacky stack; caught in infinite loop in nsBlockFrame::DoRemoveFrame

Comment 6

17 years ago
a real testcase would be appreciated.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future

Updated

16 years ago
Attachment #54855 - Attachment mime type: text/xml → application/vnd.mozilla.xul+xml

Updated

16 years ago
Attachment #54857 - Attachment is obsolete: true

Updated

16 years ago
Attachment #54855 - Attachment mime type: application/vnd.mozilla.xul+xml → text/xml

Updated

16 years ago
Whiteboard: qawanted

Comment 7

14 years ago
Does this bug still exist? I couldn't reproduce it with 2004112206 using the
attached specimens.

(Moving "qawanted" from Whiteboard to Keywords so it's caught with the others.)
Keywords: qawanted
Whiteboard: qawanted

Comment 8

12 years ago
No response in two years. Resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.