Closed Bug 1064507 Opened 7 years ago Closed 7 years ago

[Cost Control][Usage] Returning to the Usage app displays a blank screen on a device set to 319MB memory.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: Marty, Assigned: mai)

References

Details

(Keywords: qablocker, regression, Whiteboard: [273MB-Flame-Support][xfail])

Attachments

(3 files)

Description:
If the user opens the Usage app, then browses the internet, changing the current data usage values, returning to the Usage app will display a largely blank screen with only the Header and Settings 'Gear' icon displayed.

If the user selects the gear icon, then dismisses the settings screen, the usage app will redraw properly


Repro Steps:
1) Update a Flame to 20140908040204
2) Open the Usage app and set up a data limit.
3) Open the Browser and navigate the internet, increasing data usage.
4) Return to the Usage app


Actual:
Usage app is not rendered properly.


Expected:
Usage app is rendered properly.

Environmental Variables:
Device: Flame Master
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Repro frequency: 100%
See attached: screenshot, logcat

---------------------------------------------------------------------

This issue does NOT occur in Flame 2.1.
The screen updates to correct values and renders properly upon returning to the Usage app.

Environmental Variables:
Device: Flame 2.1
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (2.1)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Attached image 2014-09-08-13-01-23.png
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Hi, could you re-testing with a newest build? I cannot reproduce it with today's build
Thanks.
Flags: needinfo?(mshuman)
This issue DOES occur with the latest nightly Flame Master build.
Usage app displays a blank screen when returning after using data.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140911040205
Gaia: 7f21bdda274f0329393ef0e5a9374c06255c6f57
Gecko: bc7deafdac4b
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(mshuman)
This issue IS now occurring on Flame 2.1.
Usage app displays a blank screen when returning after using data.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140911000225
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

-----------------------------------------------------------------

This issue is NOT occuring on Flame 2.0.
The screen updates to correct values and renders properly upon returning to the Usage app.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140911000231
Gaia: ddec117b2d6ac8ea50d7fd833a9cf0605d5b358b
Gecko: 271294ee1e5a
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(pbylenga)
I'm also unable to reproduce on 2.1 but I saw this bug on reporter's device.

Marty can you do an analysis on the reproduction rate and report if there is perhaps a pre-requisite that may be missing that could be affecting this? (example: data limit set, different tracking, how many apps open, etc)
blocking-b2g: 2.2? → 2.1?
QA Whiteboard: [QAnalyst-Triage-]
Flags: needinfo?(pbylenga) → needinfo?(mshuman)
After further investigation, it appears this is a 319MB related memory issue.  I was able to reproduce this bug without a WiFi or Data network connection, and opening the Camera app and taking a picture.  I was NOT able to reproduce this bug at all using a device set to 512MB memory or on 2.0 (319MB and 512MB).

Updated STR:
1) Update a Flame device to BuildID: 20140911064110 set to 319MB memory.
2) Open the Usage app  and Set up a data alert.
3) Tap the Home button (leaving the Usage app running).
4) Open the Camera app and take a picture.
5) Tap the Home button, then tap the Usage app to re-open it.

------------------------------------------------------------------------
This issue occurred 7/7 times using these new STR on Flame Master set to 319MB memory.
Usage app displays a blank screen when returning to the app.

Environmental Variables:
Device: Flame 2.2 Master 319MB
BuildID: 20140911064110
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


This issue occurred 5/5 times using these new STR on Flame 2.1 set to 319MB memory.
Usage app displays a blank screen when returning to the app.

Environmental Variables:
Device: Flame 2.1 319MB
BuildID: 20140911000225
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

------------------------------------------------------------------------


This issue occurred 0/5 times on the above Flame Master set to 512MB.
Usage app is displayed properly when returning to the app.

This issue occurred 0/5 times on the above Flame 2.1 set to 512MB.
Usage app is displayed properly when returning to the app.

This issue occurred 0/5 times on Flame 2.0 set to 319MB.
Usage app is displayed properly when returning to the app.

Environmental Variables:
Device: Flame 2.0 319MB
BuildID: 20140911000231
Gaia: ddec117b2d6ac8ea50d7fd833a9cf0605d5b358b
Gecko: 271294ee1e5a
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
Summary: [Cost Control][Usage] Usage app displays a blank screen if data usage values have changed since it was opened. → [Cost Control][Usage] Returning to the Usage app displays a blank screen on a device set to 319MB memory.
Whiteboard: [273MB-Flame-Support]
QA Contact: jmercado
triage: per comment 7 this is an identifiable regression
blocking-b2g: 2.1? → 2.1+
Attached file patch v1.0
Hi Salva,
the error is produced when the App is killed by the oom killer. 
On this patch, I reset the value of the location hash, because when the App is relaunched after being killed, it keeps the value of its previous execution.

I'm not sure if this behaviour should be the correct, IMO when the App is relaunched, the hash should be cleared.

Regards
Attachment #8488567 - Flags: review?(salva)
Flags: needinfo?(pbylenga)
Duplicate of this bug: 1066565
Whiteboard: [273MB-Flame-Support] → [273MB-Flame-Support][xfail]
Assignee: nobody → mri
Comment on attachment 8488567 [details] [review]
patch v1.0

The patch is ok but I would prefer to take advantage of this suspend new feature and call the onhashchange handler to resume the application from the same screen it was before killed. What do you think?
Attachment #8488567 - Flags: review?(salva)
Comment on attachment 8488567 [details] [review]
patch v1.0

Updated the pr with your comments.
Would you mind reviewing again?
Regards
Attachment #8488567 - Flags: review?(salva)
Comment on attachment 8488567 [details] [review]
patch v1.0

Wow, works really well! You have a couple of nits on GitHub. Nice work!
Attachment #8488567 - Flags: review?(salva) → review+
Master: d23750c1d7df79811ca10997c47246ac97ecd712
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Please request Gaia v2.1 approval on this patch when you get a chance.
Flags: needinfo?(mri)
Target Milestone: --- → 2.1 S5 (26sep)
Comment on attachment 8488567 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature  
[User impact] if declined: Usage app is not rendered properly, when the App was killed by the oom killer. 
[Testing completed]: Tested on device
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8488567 - Flags: approval-gaia-v2.1?(release-mgmt)
Flags: needinfo?(mri)
Attachment #8488567 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Fix verified on Flame 2.2 and Flame 2.1
Actual result: After taking a picture from the Camera app or navigating through the Browser app, the Usage app will render normally when the user returns to it.

Flame 2.2
BuildID: 20141013040202
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: f547cf19d104
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20141013001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 34.0a2
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Blocks: 1098024
You need to log in before you can comment on or make changes to this bug.