firefox 31.1 SIGSEGV Segmentation fault - even in safe mode

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: doktor5000, Unassigned)

Tracking

({crash})

31 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8486015 [details]
firefox 31.1.0esr backtrace from gdb

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.137 Safari/537.36

Steps to reproduce:

Run firefox 31.1 with a fresh ~/.mozilla in safe mode, open a new tab and mouseover over one of the tiles for a few seconds or until tooltip appears. Also happens when browsing random sites, and quite often. See also https://bugs.mageia.org/show_bug.cgi?id=14062

Only bigger difference is that our firefox is compiled with clang since 31.0 due to unresolved issues with gcc >= 4.9, cf bug 1025639

full stacktrace from gdb is attached.


Actual results:

firefox crashes with a segmentation fault


Expected results:

firefox should run normally
(Reporter)

Updated

3 years ago
Severity: normal → blocker
Component: Untriaged → Layout
Keywords: crash
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
Created attachment 8486069 [details]
another firefox 31.1.0esr backtrace from gdb

Adding another backtrace.

Seems to be 100% reproducible. Open new tab page, and mouseover any tile (I've used the welcome to firefox tile) until the tooltip appears, and when moving the mouse again when tooltip should disappear, firefox crashes.


Also checked the mozilla build, and could not trigger this bug. Although firefox crashed on exit, see https://crash-stats.mozilla.com/report/index/bp-13825415-6076-4555-a16b-7f5fb2140908

Comment 2

3 years ago
(In reply to doktor5000 from comment #0)
> Only bigger difference is that our firefox is compiled with clang since 31.0
> due to unresolved issues with gcc >= 4.9, cf bug 1025639

Can you reproduce with stock 31.1 esr builds from mozilla.org?
Flags: needinfo?(doktor5000)

Comment 3

3 years ago
Err, sorry missed the tail of comment #1. The mozilla.org crashreport is different enough that I don't see how it would be related. :-(
Flags: needinfo?(doktor5000)

Updated

3 years ago
Severity: blocker → critical
(Reporter)

Comment 4

3 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> The mozilla.org crashreport is different enough that I don't see how it would be related. :-(

Yep, only added the information here for completeness sake.

I've also sent a mail to enterprise@mozilla.org asking for recommended compiler/linker but it seems the mail didn't get through yet, maybe an mailing list admin needs to approve it in moderation queue or so.

The stock 31.1esr builds from mozilla, what are they built with? gcc or clang, and what linker is used?
Interesting thing is that 31.1esr builds with gcc 4.8.x for an older distro release of Mageia doesn't show the problem, hence my question regarding compiler/linker.
(Reporter)

Comment 5

3 years ago
Got the exact same version to finally build with gcc 4.9 thanks to the patch from bug 999496 and no more crashes at all. Seems to be some issue with some compiler flags or newer clang versions above 3.4.

Somebody should take care that the changes for https://bugzilla.mozilla.org/show_bug.cgi?id=999496 also make it into 31.1.2esr branch ...


Not sure what to do with this bug now, close as WORKSFORME ?

Comment 6

3 years ago
Yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.