Closed Bug 1064595 Opened 7 years ago Closed 7 years ago

[Lockscreen] Software home button appears on lock screen

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: smiko, Assigned: Eli)

References

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-2][systemsfe])

Attachments

(2 files)

Attached image SoftHomeBut.png
Description: A nonfunctional software home button is displayed on the lock screen.

Repro Steps:
1: Update a Flame to 20140908000204
2: Open Settings > Developer > and enable software home button
3: Press Power button twice (Lock screen is displayed)

Actual:
The software home button is displayed on the lock screen but is not functional

Expected:
The software home button is not displayed on the lock screen

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%

Link to failed test case: https://moztrap.mozilla.org/manage/case/14407/

See attached: screenshot

Video clip: http://youtu.be/vB8t8i-CNwI
Rob, I think this is according to spec?
Flags: needinfo?(rmacdonald)
This issue DOES occur on Flame 2.2(319mb), Open C 2.2, Flame 2.1(512mb),Open C 2.1, Flame 2.0(319mb) and Open C 2.0

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C Master 
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1(512mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1 
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140908000202
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 8e46e547f4ad
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140908000202
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 8e46e547f4ad
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

This issue does NOT occur on Flame 1.4(319mb) or Open C 1.4

Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140905123003
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: a3e8df746cd8
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4 
Build ID: 20140905123003
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: a3e8df746cd8
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
Whiteboard: [2.1-flame-test-run-2]
Thanks for catching this, Seth. The bug is valid as per page 4 of the spec. (https://mozilla.app.box.com/s/hhuk707fmq6edpxhs7hl)

Here's the reference in the spec:

     Exceptions
     The soft home button bar is not shown in the following contexts:
     • Initial phone setup (However, the home button bar is shown during the tour)
     • Lock Screen
     • During full screen video/photo playback on select players
Flags: needinfo?(rmacdonald)
Whiteboard: [2.1-flame-test-run-2] → [2.1-flame-test-run-2][systemsfe]
[Blocking Requested - why for this release]:

Mike Henretty, Kevin Tucker, and I came to agreement that this needs to block the release. The main reason for blocking on this is this broken UX on the lockscreen, as we're showing a highly visible on the lockscreen that does nothing, even though the user would expect it to take the user to the homescreen.
blocking-b2g: --- → 2.1?
Assignee: nobody → eperelman
Status: NEW → ASSIGNED
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8488011 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23960

All good, thanks for making the layoutManager code more readable :)
Attachment #8488011 - Flags: review?(etienne) → review+
Thanks Etienne!
Keywords: checkin-needed
master: https://github.com/mozilla-b2g/gaia/commit/5c0459d61360d8adc24baff0cc02ae0d60a7a702
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 8488011 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23960

Requesting uplift to v2.1 for feature polish and buggy UX.

[Bug caused by] (feature/regressing bug #): bug 1036339
[User impact] if declined: a non-operational SHB will be present on the home screen
[Testing completed]: yes, manual and automated
[Risk to taking this patch] (and alternatives if risky): moderately low, does make a change to layout manager which affects all app window sizes
[String changes made]: n/a
Attachment #8488011 - Flags: approval-gaia-v2.1?
Depends on: 1059967
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Attachment #8488011 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Depends on: 1079525
This issue is verified fixed on Flame 2.1 & Flame 2.2:

Flame 2.1 (full flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141008000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2 (full flash)
  
Environmental Variables:
Device: Flame 2.2 Master 
BuildID: 20141008040203
Gaia: 0bc74ce502672cf0265b24cf3a25d117c3de5e71
Gecko: e4cfacb76830
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
The software home button is not displayed on the lock screen.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Integration test added in bug 1077579.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.