Closed Bug 1064664 Opened 6 years ago Closed 6 years ago

Name Sort Bar In Address Book Not Working

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

SeaMonkey 2.29 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mooreman, Unassigned)

References

Details

(Whiteboard: [fixed in Bug 1024130])

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0 SeaMonkey/2.29
Build ID: 20140904220358

Steps to reproduce:

The "Name" sort bar in SeaMonkey v2.29 Address Book does not work. 


Actual results:

After upgrading to v2.29, all of my email addresses were out of name sort order. 


Expected results:

I normally sort the list by last name, first name. If I click on the Name header, it sorts in random order. If I click on the email address sort bar, it will sort the list properly by email address.
Others (mozilla.support.seamonkey's "v2.29's addressbooks not sorting correctly in its Name column?") and I (three SMs in updated Windows (XP Pro SP3 and 64-bit 7 EE SP1) and Linux (Debian stable's 64-bit contrib) are having the same problems. I have to click on another column like Nickname and then go back to Name (last, first) to sort correctly.
Component: General → MailNews: Address Book & Contacts
Marking as New based on a number of confirming reports on mozillazine.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to therube from comment #2)
> Marking as New based on a number of confirming reports on mozillazine.
Any reports for Thunderbird?
Duplicate of this bug: 1065334
Duplicate of this bug: 1070619
(In reply to Philip Chee from comment #3)
> (In reply to therube from comment #2)
> > Marking as New based on a number of confirming reports on mozillazine.
> Any reports for Thunderbird?
Yeah, Lots. http://forums.mozillazine.org/viewtopic.php?f=29&t=2866229

Regression caused by MailNews Core Bug 177206
Fixed in Bug 1024130 for Thunderbird 33 (SeaMonkey 2
Duplicate of this bug: 1073699
Thunderbird 31.1.2 looks ok (without any issues like this, I mean).
SeaMonkey 2.29.1 still affected.
Behavior cofirmed. To get alphabetic sortment you have to switch to any other order, e.g sort by E-Mail-Adress, then sort alphabetic. Next start again more or less random-order starting with letter "b", "a"-Adresses and others placed random.
It looks like it was fixed for SeaMonkey 2.30 via Bug 1024130
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [fixed in Bug 1024130]
You need to log in before you can comment on or make changes to this bug.