Closed Bug 1064691 Opened 6 years ago Closed 6 years ago

Consumer 404 pages should be lighter

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 972495

People

(Reporter: cvan, Unassigned)

References

()

Details

With error pages, it's bad practice to include other resources, since they might also be problematic.

While the Marketplace Django (DevHub/Reviewer Tools) 404 pages <https://marketplace.firefox.com/swaglolswaglol> are still rendered by Django (which they shouldn't IMO; Kumar filed a bug about this years ago, but I can't find it atm), they're a definite improvement over the consumer pages ones.

To render a 404 page, we first download then run all of the Fireplace CSS+JS before Commonplace then does its thing: looks at the pathname, routes the user to the 404 view, and finally uses nunjucks to render the 404 template.

1. Make sure we include a search bar and a back button in the header (since the user could get stuck if viewing from within an app).
2. Have the server return a 404 page with no unnecessary CSS and no unnecessary JS and no unnecessary images and no unnecessary fonts (use the font if it's on local filesystem only).

It's worth noting that GitHub inlines all of its assets (JS, CSS, and even uses data URIs for the images) when you hit a 404 page:

view-source:https://github.com/swaglolswaglol
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972495
You need to log in before you can comment on or make changes to this bug.