Closed Bug 1064774 Opened 7 years ago Closed 7 years ago

Can't disconnect when opening debugger on an app with unavailable source map files

Categories

(Firefox OS Graveyard :: Developer Tools, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(firefox33 wontfix, firefox34 wontfix, firefox35 fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
firefox33 --- wontfix
firefox34 --- wontfix
firefox35 --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

Details

(Whiteboard: [Tako_Blocker])

Attachments

(1 file)

The protocol breaks when we try to debug https://github.com/nazar-pc/CleverStyle-Music
Once I open the debugger, I can't disconnect the runtime (and most likely other requests may broke).
It looks like an unhandled exception in this function breaks the protocol,
whereas rejecting the promise just print exceptions.
So let's reject the promise with a helpful error message...

https://tbpl.mozilla.org/?tree=Try&rev=7a165d8d92aa
Assignee: nobody → poirot.alex
Attachment #8486312 - Flags: review?(past)
Attachment #8486312 - Flags: review?(past) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1b976338e9bd
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Whiteboard: [Tako_Blocker]
hi Carsten,

since this is landed one month ago, i just want to double confirm with you if this fix is in our current 2.1 branch? (i supposed it should be already in our current 2.1 branch)

thank you very much
Flags: needinfo?(cbook)
Hi Francis,

It landed on 35, which is v2.2 for 2.1 it needs a b2g34 approval request. Please see https://wiki.mozilla.org/Release_Management/B2G_Landing#Landing_Procedure_5
Flags: needinfo?(cbook)
Alex, is this fix needed in 2.1?
Flags: needinfo?(poirot.alex)
This isn't a regression. It is just broken on all branches.
So if we consider this bug to be important for 2.1 for need to ask for its uplift.
Flags: needinfo?(poirot.alex)
Component: Developer Tools: WebIDE → Developer Tools
Product: Firefox → Firefox OS
Target Milestone: Firefox 35 → ---
Comment on attachment 8486312 [details] [diff] [review]
Prevent script actor from breaking debugger protocol on unavailable resources.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not a regression, has always been broken
User impact if declined: some apps have broken debugging experience
Testing completed: lives on trunk for quite a bit now
Risk to taking this patch (and alternatives if risky): very low, just ignore an exception 
String or UUID changes made by this patch: none
Attachment #8486312 - Flags: approval-mozilla-b2g34?
Attachment #8486312 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
You need to log in before you can comment on or make changes to this bug.