Unthemed title bar appears when changing focus from full screened Firefox, Windows

RESOLVED DUPLICATE of bug 1145448

Status

()

defect
RESOLVED DUPLICATE of bug 1145448
5 years ago
4 years ago

People

(Reporter: firefoxbugs, Unassigned)

Tracking

(Blocks 1 bug, {polish, regression})

32 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

35.34 KB, image/jpeg
Details
(Reporter)

Description

5 years ago
Posted image xxx.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140825060242

Steps to reproduce:

1. Open Firefox
2. Hit F11 to enter full screen
3. Change focus to other window (Alt+Tab or click other window in different monitor)
4. Return focus to Firefox (not really needed?)



Actual results:

Unthemed title bar appears at a top of screen.

Firefox 32, 33, 34 is affected.

Comment 1

5 years ago
(In reply to firefoxbugs from comment #0)
> Created attachment 8486315 [details]
> xxx.jpg
> 
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101
> Firefox/31.0
> Build ID: 20140825060242

> <snip>

> Firefox 32, 33, 34 is affected.

Is Firefox 31 fine? (sorry, away from my Windows machine today so I can't easily test myself)
Component: Untriaged → Theme
Flags: needinfo?(firefoxbugs)
(Reporter)

Comment 2

5 years ago
Yes, Firefox 31 is affected too.

Title bar disappears, when you move mouse over item what has some kind highlight on hover event. Also it disappears when you scroll page or in certain pages once you focus it. 
I tested with "Mozilla Firefox Start Page" and it happens always.
Flags: needinfo?(firefoxbugs)

Comment 3

5 years ago
Not able to reproduce it.

Comment 4

5 years ago
I cannot reproduce the with same steps. however, another STR can for my:
Enter to fullscreen, either toolbar button or F11 key.
Pressing Alt+Tab and hold, do not let go and return to the Firefox window by recycling the hotkey.

I saw the title bar of the image sticking when hold & straight back.
No reproduce when from another window focus back.

Comment 5

5 years ago
Supplement, tested on Firefox 33b2 in Windows 8.1.

Also, the similar to my bug 972896.

Moving to a more suitable component.
Component: Theme → Widget: Win32
Product: Firefox → Core

Comment 6

5 years ago
I've encountered this bug a lot. This bug has existed since Firefox 18 (or even earlier), since I remember seeing this often while viewing PDFs with the Adobe Reader plugin (which means this bug existed before PDF.js was shipped with Firefox in version 19).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

5 years ago
The bug exists since FF17, but the current issue is worse than the original one, because another patch has exacerbated the bug.

1) Original issue: 
In fullscreen mode, typing Alt+Tab makes the title bar blink during a few ms.
You can see this glitch again when the user returns to the Fireox window and releases the keyboard shortcut (Alt+Tab).
Regression range:
good=2012-08-21
bad1=2012-08-22
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=360ab7771e27&tochange=abc17059522b

My guess goes to this suspected bug:
Dão Gottwald — Bug 783103 - Avoid layout flush from isElementVisible when attempting to focus the URL bar or search bar. r=enn

2) Current issue:
Pressing Alt+Tab makes the title bar appear permanently, releasing the shortcut has no effect, the user needs to scroll or move the mouse pointer over the title bar to make it disappear.
Regression range:
bad1=2013-09-27
bad2=2013-09-28
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3ad5ecf34c9e&tochange=2f4397db1830

My guess goes to:
Markus Stange — Bug 532828 - Don't invalidate the whole window on window activation/deactivation. r=roc
Keywords: regression

Comment 8

4 years ago
I'm not sure what to do in this case. Bug 968526 is older and has duplicates. But this bug has more people CC'd and possibly more information? Which bug should be marked as a dupe?

Comment 9

4 years ago
Actually, bug 940609 is older still.

Updated

4 years ago
Duplicate of this bug: 968526

Updated

4 years ago
Blocks: 1121280

Updated

4 years ago

Updated

4 years ago
Duplicate of this bug: 972896

Updated

4 years ago
Duplicate of this bug: 940609

Updated

4 years ago
Duplicate of this bug: 1109224

Updated

4 years ago
Duplicate of this bug: 876464

Comment 15

4 years ago
(In reply to Loic from comment #7)
> ..
> 1) Original issue: 
> In fullscreen mode, typing Alt+Tab makes the title bar blink during a few ms.
> You can see this glitch again when the user returns to the Fireox window and
> releases the keyboard shortcut (Alt+Tab).
> Regression range:
> good=2012-08-21
> bad1=2012-08-22.
> ..
I don't get the same results unfortunately. (Regression range incoming, see next comment.)

(In reply to Loic from comment #7)
> ..
> 2) Current issue:
> Pressing Alt+Tab makes the title bar appear permanently, releasing the
> shortcut has no effect, the user needs to scroll or move the mouse pointer
> over the title bar to make it disappear.
> Regression range:
> bad1=2013-09-27
> bad2=2013-09-28
> ..
I backtracked to 2013-09-20 and the bug persists.

Comment 16

4 years ago
regressionwindow
Regression window:
> Narrowed nightly regression window from [2012-08-19, 2012-08-21] (2 days) to [201>
> 2-08-20, 2012-08-21] (1 days) (~0 steps left)
> Got as far as we can go bisecting nightlies...
> Last good revision: c676b554c7bb
> First bad revision: 1b51c7bf1e05
> Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c676b554c7bb&tochange=1b51c7bf1e05

With the build from 2012-08-20 I can't reproduce the bug, the title-bar does however appear when transitioning to/from fullscreen. But this might go away if the underlying problem is fixed (this bug).

Comment 17

4 years ago
> http://hg.mozilla.org/mozilla-central/rev/27f8a4f62506
> Tim Abraldes — bug 758280. Refactor the way we handle `WM_NCCALCSIZE` 
> messages and how we keep track of our frame offsets. r=jimm

Jim, could the above be relevant to what going on here? Please forgive me for poking you if this incorrect. :) /ducks
Flags: needinfo?(jmathies)

Comment 18

4 years ago
Bug-note: I can only reproduce this with Aero enabled (the Basic and Classic themes work fine).
> With the build from 2012-08-20 I can't reproduce the bug, the title-bar does
> however appear when transitioning to/from fullscreen. 

This bug has been around a while.
Flags: needinfo?(jmathies)
(In reply to Johan C from comment #17)
> > http://hg.mozilla.org/mozilla-central/rev/27f8a4f62506
> > Tim Abraldes — bug 758280. Refactor the way we handle `WM_NCCALCSIZE` 
> > messages and how we keep track of our frame offsets. r=jimm
> 
> Jim, could the above be relevant to what going on here? Please forgive me
> for poking you if this incorrect. :) /ducks

Maybe? Easiest way to confirm that is to back out the offending patch and see if it fixes the problem. Although on a bug this old, might be better to just look for a good fix.
Keywords: polish

Updated

4 years ago
See Also: → 1145448

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145448
You need to log in before you can comment on or make changes to this bug.