TEST-UNEXPECTED-FAIL | older-widget/test-message-filters.js | test-message-filters.js::test_customize_toolbar_doesnt_double_get_mail_menu

RESOLVED FIXED in Thunderbird 36.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: standard8, Assigned: hiro)

Tracking

({intermittent-failure})

Trunk
Thunderbird 36.0
All
Linux
intermittent-failure

Thunderbird Tracking Flags

(thunderbird35 fixed, thunderbird36 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Seems to be debug builds on Linux, may be related to bug 904152 and bug 871266. Not sure if this has reappeared recently, or if its always been about.

https://tbpl.mozilla.org/php/getParsedLog.php?id=47663194&tree=Thunderbird-Trunk#error3

TEST-START | /builds/slave/test/build/mozmill/folder-widget/test-message-filters.js | test_customize_toolbar_doesnt_double_get_mail_menu
Step Pass: {"function": "controller.click()"}
Step Pass: {"function": "controller.click()"}
Step Pass: {"function": "Controller.keypress()"}
Step Pass: {"function": "Controller.keypress()"}
Step Pass: {"function": "controller.rightClick()"}
++DOCSHELL 0x7ff5dcd76000 == 13 [pid = 2799] [id = 13]
++DOMWINDOW == 33 (0x7ff5dcdcc400) [pid = 2799] [serial = 33] [outer = (nil)]
++DOMWINDOW == 34 (0x7ff5df99d800) [pid = 2799] [serial = 34] [outer = 0x7ff5dcdcc400]
Step Pass: {"function": "controller.click()"}
Step Pass: {"function": "Controller.keypress()"}
Step Pass: {"function": "controller.click()"}
Step Pass: {"function": "controller.click()"}
Test Failure: Timeout waiting for popup to open
++DOCSHELL 0x7ff5dc792800 == 14 [pid = 2799] [id = 14]
++DOMWINDOW == 35 (0x7ff5db0a7c00) [pid = 2799] [serial = 35] [outer = (nil)]
++DOMWINDOW == 36 (0x7ff5db2e0800) [pid = 2799] [serial = 36] [outer = 0x7ff5db0a7c00]
[2799] WARNING: NS_ENSURE_TRUE(msgDocShellItem) failed: file /builds/slave/tb-c-cen-l64-d-000000000000000/build/mailnews/base/src/nsMsgWindow.cpp, line 92
[2799] WARNING: NS_ENSURE_TRUE(msgDocShellItem) failed: file /builds/slave/tb-c-cen-l64-d-000000000000000/build/mailnews/base/src/nsMsgWindow.cpp, line 92
[2799] WARNING: NS_ENSURE_TRUE(msgDocShellItem) failed: file /builds/slave/tb-c-cen-l64-d-000000000000000/build/mailnews/base/src/nsMsgWindow.cpp, line 92
++DOCSHELL 0x7ff5dcd5d800 == 15 [pid = 2799] [id = 15]
++DOMWINDOW == 37 (0x7ff5db2e6c00) [pid = 2799] [serial = 37] [outer = (nil)]
++DOMWINDOW == 38 (0x7ff5dbc32000) [pid = 2799] [serial = 38] [outer = 0x7ff5db2e6c00]
TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/folder-widget/test-message-filters.js | test-message-filters.js::test_customize_toolbar_doesnt_double_get_mail_menu
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 10

4 years ago
For the record (if we decide to close this in the future), this currently stopped appearing after fixing bug 1054357. Let's see if this isn't just a false alarm.
Comment hidden (Treeherder Robot)

Comment 12

4 years ago
OK, this one was false alarm :)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 38

3 years ago
Created attachment 8526545 [details] [diff] [review]
Use click_menus_in_sequence instead of opening popups respectively

https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=a1a06aa00dde

There were lots of failures but most of those are bug 1102588.
There was one failure of this issue. The failure is as I expected. I don't think this patch will eliminate failure, I just think it will make the code simple. And I hope it will make the rate of failures reducing.
Attachment #8526545 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 39

3 years ago
(In reply to Hiroyuki Ikezoe (:hiro) from comment #38)
> Created attachment 8526545 [details] [diff] [review]
> Use click_menus_in_sequence instead of opening popups respectively
> 
> https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-
> central&revision=a1a06aa00dde
> 
> There were lots of failures but most of those are bug 1102588.
> There was one failure of this issue. The failure is as I expected. I don't
There were two failures actually.

Comment 40

3 years ago
Comment on attachment 8526545 [details] [diff] [review]
Use click_menus_in_sequence instead of opening popups respectively

Review of attachment 8526545 [details] [diff] [review]:
-----------------------------------------------------------------

Unfortunately, this is exactly what was in the code in the past, but was changed due to it not working right, see https://hg.mozilla.org/comm-central/rev/13c5e7a669b6 (bug 871266). So do you have an idea why it would work today?
Attachment #8526545 - Flags: feedback-
(Assignee)

Comment 41

3 years ago
I don't know much about at that time.  So I just pushed two tries:

Enable test_customize_toolbar_doesnt_double_get_mail_menu on Mac with attachment 8526545 [details] [diff] [review]:
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=e3532a5a7912

Just enable the test on Mac:
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=bc2b5306e03d
(Assignee)

Comment 42

3 years ago
Oh my god. I forgot the current mac build is busted.
(Assignee)

Comment 43

3 years ago
Following tries will be built on Mac.

Enable test_customize_toolbar_doesnt_double_get_mail_menu on Mac with attachment 8526545 [details] [diff] [review]
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=436d71d41757

Just enable the test on Mac:
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=23340e52ca2b
(Assignee)

Comment 44

3 years ago
I am sorry that the previous tries failed too.
I will post the results after the mac build is done correctly.
(Assignee)

Comment 45

3 years ago
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=852e99158b0d

This one was a try which is just enabled test_customize_toolbar_doesnt_double_get_mail_menu. Then the test failed. So the failure on Mac should be handled as a separate issue.
(Assignee)

Comment 46

3 years ago
Ah, on Mac menu bar is not on Thunderbird window. So test_customize_toolbar_doesnt_double_get_mail_menu fails.

Comment 47

3 years ago
Maybe that is the problem. Can you try to use the appmenu?
(Assignee)

Comment 48

3 years ago
(In reply to :aceman from comment #47)
> Maybe that is the problem. Can you try to use the appmenu?

Using appmenu failed on my linux box. You mean using appmenu only for Mac?
(Assignee)

Comment 49

3 years ago
OK. I don't understand XUL menu stack at all...
I tried first to wait for appmenu_FilePopup, but it did not work as I expected.

aceman, this is for you. Using appmenu_File:
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=17cfe3a7a5ad

Comment 50

3 years ago
Looks like I was a bit wrong in comment 40. The change in the test from click_menus_in_sequence to individual .click() calls was not actually done. It was the other way round. I wanted to convert the test to click_menus_in_sequence, but it didn't stick and was backed out in bug 871266. So the attachment https://bugzilla.mozilla.org/attachment.cgi?id=781874 is still pending and not landed. You can see I do convert to appmenu there but also do some more changes to support OS X special Customize dialog. Maybe you need to revive that parts too? I'd love to finish that but I can't test on OS X. Maybe Josiah can help us.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 55

3 years ago
Created attachment 8527261 [details] [diff] [review]
Fix

I found finally the cause of this failure.

On linux, popup menu disappears if window which owning the popup menu is surely focused. So we need to wait for the focus before popping up menu.

I was surprised that there is a wait_for_window_focused() before the first popup in test_customize_toolbar_doesnt_double_get_mail_menu. So I guessed the guy who inserted the wait_for_window_focused() knew the focus behaviour on Linux.
I was then very surprised the guys is ME! My dull brain!

There were several tries waiting for the focus. There is no oranges for this issue! 
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=5ad44d34a75a

Attaching patch is slightly different from the try one but basically it's the same.
I just pushed the attaching patch on try once for the safety. (The bug number was wrong though)
https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=b7071d60b995
Attachment #8526545 - Attachment is obsolete: true
Attachment #8526545 - Flags: review?(mkmelin+mozilla)
Attachment #8527261 - Flags: review?(mkmelin+mozilla)

Comment 56

3 years ago
Comment on attachment 8527261 [details] [diff] [review]
Fix

Great! r=mkmelin
Attachment #8527261 - Attachment is patch: true
Attachment #8527261 - Flags: review?(mkmelin+mozilla) → review+

Comment 57

3 years ago
https://hg.mozilla.org/comm-central/rev/2800c19003aa -> FIXED
Assignee: nobody → hiikezoe
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
(Reporter)

Comment 58

3 years ago
Landed for beta with a=test-only:

https://hg.mozilla.org/releases/comm-beta/rev/0984fcdaddbd
status-thunderbird35: --- → fixed
(Reporter)

Updated

3 years ago
status-thunderbird36: --- → fixed
You need to log in before you can comment on or make changes to this bug.