Activate browser_timelineMarkers-02.js for e10s

RESOLVED FIXED in Firefox 35

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: pbro, Assigned: pbro)

Tracking

unspecified
Firefox 35
Points:
---

Firefox Tracking Flags

(e10s+)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Test browser_timelineMarkers-02.js fails in e10s mode with the following error messages:

10 INFO TEST-PASS | chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js | markers were returned 
11 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js | markers includes Reflow - 
Stack trace:
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:TESTS<.check:24
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:test<:80
    Tester_execTest@chrome://mochikit/content/browser-test.js:659:9
    Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:556:7
12 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js | markers includes Paint - 
Stack trace:
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:TESTS<.check:25
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:test<:80
    Tester_execTest@chrome://mochikit/content/browser-test.js:659:9
    Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:556:7
13 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js | markers includes Restyle - 
Stack trace:
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:TESTS<.check:26
    chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js:test<:80
    Tester_execTest@chrome://mochikit/content/browser-test.js:659:9
    Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:556:7
14 INFO Console message: [JavaScript Warning: "XrayWrapper denied access to property name (reason: object is not safely Xrayable). See https://developer.mozilla.org/en-US/docs/Xray_vision for more information. Note that only the first denied property access from a given global object will be reported." {file: "chrome://mochitests/content/browser/docshell/test/browser/browser_timelineMarkers-02.js" line: 24}]

and more ...

The interesting bit here is "XrayWrapper denied access to property name (reason: object is not safely Xrayable)" line: 24.

This means that, in e10s mode, the test gets an XRayWrapper for the array of markers returned by popProfileTimelineMarkers and for some reason, markers' names aren't considered as native properties that can safely be accessed, hence the test fails.

It has been deactivated for now.
For inspiration, bholley made some elaborate changes to the console previewers for a similar reason:

http://dxr.mozilla.org/mozilla-central/source/toolkit/devtools/server/actors/script.js#3599
tracking-e10s: --- → +
(Assignee)

Comment 2

4 years ago
(In reply to Panos Astithas [:past] from comment #1)
> For inspiration, bholley made some elaborate changes to the console
> previewers for a similar reason:
> 
> http://dxr.mozilla.org/mozilla-central/source/toolkit/devtools/server/actors/
> script.js#3599
Thanks, that seems to be what I need.
However, I can't seem the reproduce the problem anymore, running the test with '--e10s' without changing the code makes the test pass!
Did something change recently?
(Assignee)

Comment 3

4 years ago
Alright, so it does look like something changed. Here is a try push that just removes the |skip-if| condition in browser.ini: https://tbpl.mozilla.org/?tree=Try&rev=adcc5f534e66
Looks like all tests pass in e10s mode.
(Assignee)

Comment 4

4 years ago
Created attachment 8489603 [details] [diff] [review]
bug1064848-timeline-e10s-test.patch

R+ myself as this is only a minor browser.ini change that enables a test.
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Attachment #8489603 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/ab5a6bea66bf
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ab5a6bea66bf
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Sorry for the spam. Moving bugs to Firefox :: Developer Tools: Performance Tools (Profiler/Timeline).

dkl
Component: Developer Tools: Timeline → Developer Tools: Performance Tools (Profiler/Timeline)
You need to log in before you can comment on or make changes to this bug.