media queries are not shown in "inspect" tab "rules" sidebar

RESOLVED DUPLICATE of bug 1120570

Status

()

Firefox
Developer Tools: Inspector
P2
normal
RESOLVED DUPLICATE of bug 1120570
3 years ago
2 years ago

People

(Reporter: cotne.95, Unassigned)

Tracking

34 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-backlog][difficulty=medium])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.24 Safari/537.36

Steps to reproduce:

write some css with media queries


Actual results:

media queries not shown in sidebar


Expected results:

media queries must be shown in sidebar like in chrome devtools
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Inspector
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: media query are not shown in "inspect" tab "rules" sidebar → Rules in media queries that do not currently apply are not shown in "inspect" tab "rules" sidebar
(In reply to cotne.95 from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36
> (KHTML, like Gecko) Chrome/38.0.2125.24 Safari/537.36
> 
> Steps to reproduce:
> 
> write some css with media queries
> 
> 
> Actual results:
> 
> media queries not shown in sidebar
> 
> 
> Expected results:
> 
> media queries must be shown in sidebar like in chrome devtools

I'm actually confused. I thought you meant media queries that didn't apply, because media queries which *are* applied do show in the rules tab for the inspector.

However, media queries that do not apply do not show in the chrome devtools, either. Here's a dumb testcase:

http://jsbin.com/fuyufu/1/edit

you can toggle whether the media query applies by manipulating the width of the "result" sidebar.

When the media query applies, the rule for <p> shows up with a header of:

inline:11  @media all and (max-width: 300px)

which seems correct to me?

Can you provide more details as to what you think is not working right?
Flags: needinfo?(cotne.95)
(Reporter)

Updated

3 years ago
Flags: needinfo?(cotne.95)
Summary: Rules in media queries that do not currently apply are not shown in "inspect" tab "rules" sidebar → media queries are not shown in "inspect" tab "rules" sidebar
(Reporter)

Comment 2

3 years ago
i think it was google translate mistake i have changed title

and here is screenshot http://imgur.com/CjKDgfx
What version did you use - is 34 (the version field) correct?

It's odd because on 34 (aurora), on OS X, the testcase shows me http://i.imgur.com/9lSYQNA.png . It could be that this is Windows-specific; I'll have a look at my Windows machine in a bit.
Flags: needinfo?(cotne.95)
(Reporter)

Comment 4

3 years ago
screenshot was taken from 35 version but 34 is same 
i tested this with win7 and win8.1 with ff 34 and 35 
media query is not shown
Flags: needinfo?(cotne.95)
Whiteboard: [
Whiteboard: [ → [devedition-40]
Setting devedition-40 bugs to P2, filter on C17C996C-A0BE-4153-8057-FAB642D0746D
Priority: -- → P2
Whiteboard: [devedition-40] → [devedition-40][difficulty=medium]
Duplicate of this bug: 1097977
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120570
Whiteboard: [devedition-40][difficulty=medium] → [polish-backlog][difficulty=medium]
You need to log in before you can comment on or make changes to this bug.