Trying to download a file and give me an block download error

RESOLVED DUPLICATE of bug 1062966

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 1062966
4 years ago
4 years ago

People

(Reporter: deepanshu2017, Unassigned)

Tracking

({ux-control})

32 Branch
x86_64
All
ux-control
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20140804060850

Steps to reproduce:

Steps
1. Go to http://www.emptyloop.com/unlocker/#download
2. Select a download for 64 bit windows
3. Hit on The first one: Unlocker 1.9.2 - 32 and 64 bit version
4. Hit on save file


Actual results:

The download manager shows that the file is blocked and I can't use it. I know it may contains viruses but the same file I can download with the other site! And as far as the issue of blocking the site is concerned this site http://www.emptyloop.com/unlocker/#download is not blocked by the stopbadware.org. 


Expected results:

If the file or the site is blocked than Firefox should show a message related to the site information or about the file that is blocked!

Comment 1

4 years ago
It happens with both Windows and Linux, so it is not because of antivirus software.  Disabling blocking of malware makes the download work, but it still is unclear what the problem is.
Status: UNCONFIRMED → NEW
Component: Untriaged → Downloads Panel
Ever confirmed: true
Keywords: ux-control
OS: Linux → All
deepanshu, most likely https://bugzilla.mozilla.org/show_bug.cgi?id=1053890 will fix your problem. It allows you to recover downloaded malware. I suspect this error was transient, because I can't reproduce on Firefox or Chrome right now.

It's also possible that the warning was correct.

Comment 3

4 years ago
(In reply to [:mmc] Monica Chew (please use needinfo) from comment #2)
> deepanshu, most likely https://bugzilla.mozilla.org/show_bug.cgi?id=1053890
> will fix your problem. It allows you to recover downloaded malware. I
> suspect this error was transient, because I can't reproduce on Firefox or
> Chrome right now.
> 
> It's also possible that the warning was correct.

This UI isn't implemented yet, though, it seems? Are we planning on shipping the current state in 34 or will it be turned off there? (I presume that the UI will require strings, so it's too late for 34 now)
Flags: needinfo?(mmc)
(In reply to :Gijs Kruitbosch from comment #3)
> (I presume that the
> UI will require strings, so it's too late for 34 now)

afaik the plan was to uplift bug 1063105, not sure if it changed.

Comment 5

4 years ago
Apparently the file (and not just its source) is adware, and can install some unwanted things, but some users still like it: https://www.virustotal.com/en/file/b3284358029388637e642077f99e81e81144d8dab2f2623e263dbb5b625be746/analysis/

bug 1048508 has people complaining about it blocking Firefox OS images.

Duping to a bug that contains a plan to, and hopefully will, add "Learn more" and (through bug 1048508) "Unblock" links.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053890
(In reply to :Gijs Kruitbosch from comment #3)

> This UI isn't implemented yet, though, it seems? Are we planning on shipping
> the current state in 34 or will it be turned off there? (I presume that the
> UI will require strings, so it's too late for 34 now)

It will not ship regardless of version until the !RELEASE_VERSION is taken away:
https://hg.mozilla.org/mozilla-central/rev/452f87c15124

This will require bug 1062966 to be fixed. The strings for it are in bug 1063105
which indeed should be uplifted to 34 ASAP.

If bug 1062966 can be fixed in time and uplifted, then we can ship in 34 by
removing the RELEASE_VERSION define.
Flags: needinfo?(mmc)
Duplicate of bug: 1062966
You need to log in before you can comment on or make changes to this bug.