Closed Bug 10650 Opened 20 years ago Closed 18 years ago

[GTK Themes] Mismatched GTK versions between mozilla binary and theme

Categories

(Core :: XUL, defect, P5)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: jsadusk, Assigned: pavlov)

References

Details

(Keywords: crash, relnote, Whiteboard: [nsbeta2-])

If any gtk theme is active when mozilla starts it crashes immediately with a bunch of linker errors.
The errors are as follows:
GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

Gtk-WARNING **: gtk_type_create(): unknown parent type `39445'.

GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

GLib-CRITICAL **: file ghash.c: line 152 (g_hash_table_insert): assertion `hash_table != NULL' failed.

GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

GLib-CRITICAL **: file ghash.c: line 152 (g_hash_table_insert): assertion `hash_table != NULL' failed.

Gtk-WARNING **: gtk_arg_type_new(): argument class in "GtkHScrollbar::adjustment" is not in the `GtkObject' ancestry

GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

GLib-CRITICAL **: file ghash.c: line 152 (g_hash_table_insert): assertion `hash_table != NULL' failed.

Gtk-WARNING **: gtk_arg_type_new(): argument class in "GtkVScrollbar::adjustment" is not in the `GtkObject' ancestry

Gtk-CRITICAL **: file gtktypeutils.c: line 341 (gtk_type_class): assertion `node != NULL' failed.

In specific this is the GTKStep theme but it seems to happen with every theme including pixmap based ones
Assignee: trudelle → pavlov
reassigning to pavlov for M15
Severity: minor → enhancement
Status: NEW → ASSIGNED
Summary: Crash on startup if any gtk theme is activated → [GTK Themes] Crash on startup if any gtk theme is activated
Target Milestone: M15
I am assuming that you are using a nightly build or a milestone release.  More
than likely, this version you are using is compiled against a different version
of GTK than the one that is on your system, causing the loading of the themes to
get confused and not load.  You should not see this problem if you build your
own copy of mozilla.  Leaf and shaver and I have talked about this, so I am
adding them to the cc list.
Severity: enhancement → normal
Summary: [GTK Themes] Crash on startup if any gtk theme is activated → [GTK Themes] Mismatched GTK versions between mozilla binary and theme
Target Milestone: M15 → M13
this is pretty important that we address this for beta i think so that people
will actually be able to run this if their system has different versions of GTK
than the one we linked with... if we link dynamically this shouldn't be a real
problem.
*** Bug 9689 has been marked as a duplicate of this bug. ***
*** Bug 9689 has been marked as a duplicate of this bug. ***
mass-moving all m13 bugs to m14
giving me rest of phillips open qa contact bugs, sorry for spam
Summary: [GTK Themes] Mismatched GTK versions between mozilla binary and theme → [CRASH] [GTK Themes] Mismatched GTK versions between mozilla binary and theme
Severity: normal → critical
Putting on beta1 radar.
Keywords: beta1
Is this still a valid bug?
Old bug...no answer. Putting on PDT- radar for beta1.
Whiteboard: [PDT-]
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash
Severity: critical → normal
Keywords: beta1
Priority: P3 → P5
Target Milestone: M14 → M20
Summary: [CRASH] [GTK Themes] Mismatched GTK versions between mozilla binary and theme → [GTK Themes] Mismatched GTK versions between mozilla binary and theme
*IGNORE* - more massive spam, changing open XPToolkit bug's QA contact to
jrgm@netscape.com

QA Contact: paulmac → jrgm
Mass move of all M20 bugs to M30.
Mass move of M20 bugs to M30
Target Milestone: M20 → M30
Flagging nsbeta2 to get this issue some attention; if it's now a non-issue, 
let's close this bug, but otherwise it's at least a "relnote".

Gerv
Keywords: nsbeta2
[nsbeta2-] adding relnote keyword. Pav, do you still think we need to fix this?
Keywords: relnote
Whiteboard: [PDT-] → [nsbeta2-]
Mass-moving all M20-M30 XPToolkit bugs to Future
Target Milestone: M30 → Future
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note. If anyone feels it does, can they please draft one and then 
nominate with the relnote-user or relnote-rtm strings in the Status Whiteboard.

Thanks :-)

Gerv
I can't reproduce this, I'm using a gtk theme (graphite) and debian/sid.  Is
this even a problem anymore?

ii  libgtk1.2      1.2.10-1       The GIMP Toolkit set of widgets for X
ii  gtk-engines-pi 0.12-3         Pixmap-based theme for GTK+
i think this is long gone... perhaps it still exists, but i think that gtk
hasn't changed enough recently for this to be a real issue.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.