[Skia] Remove Moz2D requirement for SK_SUPPORT_LEGACY_GETTOPDEVICE

RESOLVED FIXED in mozilla35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wlitwinczyk, Assigned: wlitwinczyk)

Tracking

unspecified
mozilla35
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

5 years ago
This is a deprecated API, but FF doesn't use it. Removing the define so it's not accidentally used.
Assignee

Comment 1

5 years ago
Posted patch skia_bug_legacy_gettop_device (obsolete) — Splinter Review
Attachment #8486584 - Flags: review?(gwright)
Attachment #8486584 - Flags: review?(gwright) → review+
Assignee

Comment 3

5 years ago
Updated patch so it would apply correctly. Before I was waiting for bug 1046918 to land first, but I've decided it's quicker to land this one first.

Try: https://tbpl.mozilla.org/?tree=Try&rev=af5fa556bfd0
Attachment #8486584 - Attachment is obsolete: true
Attachment #8491770 - Flags: review+
Assignee

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f73db3f43481
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.