If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No process name for the GMP process in the mochitest log

RESOLVED FIXED in mozilla35

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mccr8, Assigned: mccr8)

Tracking

unspecified
mozilla35
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
When things get added to the log, like NS_WARNING output, it adds information about the process.  For a content child process, it prints out that it is a child process:
  17:51:19     INFO -  [Child 1802] WARNING: ...
Similarly in the parent process.

However, for the geckomediaplugin, it just does:
  17:56:48     INFO -  [2257] WARNING: ...

The Gecko Media Plugin stuff is a new kind of process, so presumably there just needs to be a new case added somewhere.  It would make interpreting the logs easier.  I don't actually know where this code lives that produces that process output.
(Assignee)

Comment 1

3 years ago
automationutils stuff uses geckomediaplugin as the name, but maybe just GMP here would be good, so the lines don't all get too long.
I think you just need a call like this in the GMPChild:
http://hg.mozilla.org/mozilla-central/annotate/4d1793da0b96/dom/ipc/ContentChild.cpp#l524
(Assignee)

Updated

3 years ago
Component: Mochitest → Video/Audio
Product: Testing → Core
(Assignee)

Comment 3

3 years ago
Ah, great, I would not have guessed that.
Assignee: nobody → continuation
(Assignee)

Comment 4

3 years ago
Created attachment 8487428 [details] [diff] [review]
Enable logging of GMP process name.

I confirmed that this works, though it looks like some of the very early "WARNING: XPCOM objects created/destroyed from static ctor/dtor" spam doesn't get annotated.

try run: https://tbpl.mozilla.org/?tree=Try&rev=929b76bb71f5
Attachment #8487428 - Flags: review?(rjesup)

Updated

3 years ago
Attachment #8487428 - Flags: review?(rjesup) → review+
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b58fabead3f9
https://hg.mozilla.org/mozilla-central/rev/b58fabead3f9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Flags: qe-verify+
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.