If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Clock][SHB] 'Stopwatch' in Timer settings overlaps the 'vibrate' toggle while in Card View

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Clock
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [shb-enabled])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8486676 [details]
Clock.png

Description:
'Stopwatch' Text string in the Clock app is overlapping the 'Vibrate' toggle for the 'Timer' settings.

Repro Steps:
1) Update a Flame device to BuildID: 20140909040219
2) Open Settings app and turn on developer mode
3) Enable Software Home Button
4) Open the Clock app
5) Select the 'Timer' page
6) Long press on the Software Home Button

Actual:
The text string 'Stopwatch' overlaps the 'Vibrate' toggle in the 'Timer' settings.

Expected: 
The 'Stopwatch' text string does not overlap.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140909040219
Gaia: 4acd3e69b263b54f4111e3586ff4ade84b49b4da
Gecko: 6b8da5940f74
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8486682 [details]
log.txt

Issue DOES occur on 2.1 Flame 319MB

Environmental Variables:
Device: Flame 2.1 319MB
BuildID: 20140909000204
Gaia: c7b55ed3be126b1f5f3d9cdd0277c365a6652d29
Gecko: 956b152e6d21
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(pbylenga)
QAWanted for branch checks to see if this is a regression.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This bug repro's on: Flame 2.2, Flame 2.1, OpenC 2.2

Actual Results: 'Stopwatch' Text string in the Clock app is overlapping the 'Vibrate' toggle for the 'Timer' settings.

Repro Rate: 3/3

Device: Flame 2.2
BuildID: 20140910060915
Gaia: f108c706fae43cd61628babdd9463e7695b2496e
Gecko: 843332cc69af
Version: 35.0a1 (2.2)
Firmware: V123
-----------------------------------------------
Device: Open_C 2.2
BuildID: 20140910060915
Gaia: f108c706fae43cd61628babdd9463e7695b2496e
Gecko: 843332cc69af
Version: 35.0a1 (2.2)
Firmware: P821A10v1.0.0B06_LOG_DL
-----------------------------------------------
Device: Flame 2.1
BuildID: 20140910122556
Gaia: 6cb9de2c10070dc638ed9bc083ad5ff9a065db36
Gecko: fcbfbd3cba3f
Version: 34.0a2 (2.1)
Firmware: V123

------------------------------------------------
------------------------------------------------

This bug does NOT repro on: Flame 2.0, Flame 1.4

Actual Result: Correct Spacing between vibration toggle and Stopwatch.

Repro Rate: 0/2 attempts

Environmental Variables:
Device: Flame 2.0
BuildID: 20140910075715
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 0b64a36a0378
Version: 32.0 (2.0) 
Firmware Version: v123
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140905100238
Gaia: 2ee5b00bfbb8a67a967094804390b4afce8ecf54
Gecko: a3e8df746cd8
Version: 30.0 (1.4) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
[Blocking Requested - why for this release]: Regression, really bad looking bug
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Had seconds thoughts about this nom. It really is just a visual/graphic bug and the user can still tell what the app is / which is the card view's function. A bug worthy of fixing, but not blocking on.
blocking-b2g: 2.1? → ---
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → jmitchell@qanalydocs.com

Updated

3 years ago
QA Whiteboard: jmitchell@qanalydocs.com → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(m)
I cannot reproduce this on master. Given that there were no related Clock changes between 2.2 and master, it's possible that this was a gfx bug or something else unrelated. Closing as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(m)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.