Status

Firefox OS
Wifi
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: ack, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
I can connect initially, but wpa_supplicant goes away after disconnecting and trying to reconnect.

I/QCOM PowerHAL(  295): Got set_interactive hint
E/QCOM PowerHAL(  295): Invalid hint ID.
D/qdhwcomposer(  295): hwc_blank: Unblanking display: 0
D/qdhwcomposer(  295): hwc_blank: Done unblanking display: 0
D/QualcommSoftapCmd(  269): Got softap fwreload command we are passing on
D/SoftapController(  269): Softap fwReload - Ok
I/Gecko   (  295): WifiWorker::associateMesh
E/WifiHW  (  295): Unable to open connection to supplicant on "wlan0": No such file or directory
D/wpa_supplicant( 1330): wpa_supplicant v2.1-devel-4.3
D/wpa_supplicant( 1330): Add randomness: count=1 entropy=0
D/wpa_supplicant( 1330): random pool - hexdump(len=128): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=8): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random pool - hexdump(len=128): [REMOVED]
D/wpa_supplicant( 1330): random: Added entropy from /data/misc/wifi/entropy.bin (own_pool_ready=2)
D/wpa_supplicant( 1330): random: Trying to read entropy from /dev/random
D/wpa_supplicant( 1330): Get randomness: len=20 entropy=1
D/wpa_supplicant( 1330): random from os_get_random - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random from internal pool - hexdump(len=16): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random from internal pool - hexdump(len=16): [REMOVED]
D/wpa_supplicant( 1330): mixed random - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random: Updated entropy file /data/misc/wifi/entropy.bin (own_pool_ready=2)
I/wpa_supplicant( 1330): Successfully initialized wpa_supplicant
D/wpa_supplicant( 1330): Initializing interface 'wlan0' conf '/data/misc/wifi/wpa_supplicant.conf' driver 'nl80211' ctrl_interface 'N/A' bridge 'N/A'
D/wpa_supplicant( 1330): Configuration file '/data/misc/wifi/wpa_supplicant.conf' -> '/data/misc/wifi/wpa_supplicant.conf'
D/wpa_supplicant( 1330): Reading configuration file '/data/misc/wifi/wpa_supplicant.conf'
D/wpa_supplicant( 1330): ctrl_interface='wlan0'
D/wpa_supplicant( 1330): disable_scan_offload=1
D/wpa_supplicant( 1330): update_config=1
D/wpa_supplicant( 1330): p2p_disabled=1
D/wpa_supplicant( 1330): p2p_no_group_iface=1
D/wpa_supplicant( 1330): Line: 7 - start of a new network block
D/wpa_supplicant( 1330): ssid - hexdump(len=8): 6f 70 65 6e 6d 65 73 68
D/wpa_supplicant( 1330): key_mgmt: 0x4
D/wpa_supplicant( 1330): priority=2 (0x2)
D/wpa_supplicant( 1330): mode=1 (0x1)
D/wpa_supplicant( 1330): frequency=2457 (0x999)
D/wpa_supplicant( 1330): Priority group 2
D/wpa_supplicant( 1330):    id=0 ssid='openmesh'
D/wpa_supplicant( 1330): nl80211: interface wlan0 in phy phy0
I/wpa_supplicant( 1330): rfkill: Cannot open RFKILL control device
D/wpa_supplicant( 1330): nl80211: RFKILL status not available
D/wpa_supplicant( 1330): nl80211: Set mode ifindex 22 iftype 2 (STATION)
D/wpa_supplicant( 1330): nl80211: Failed to set interface 22 to mode 2: -95 (Operation not supported on transport endpoint)
D/wpa_supplicant( 1330): nl80211: Try mode change after setting interface down
D/wpa_supplicant( 1330): nl80211: Set mode ifindex 22 iftype 2 (STATION)
D/wpa_supplicant( 1330): nl80211: Failed to set interface 22 to mode 2: -95 (Operation not supported on transport endpoint)
D/wpa_supplicant( 1330): nl80211: Interface mode change to 2 from 0 failed
E/wpa_supplicant( 1330): nl80211: Could not configure driver to use managed mode
D/wpa_supplicant( 1330): netlink: Operstate: linkmode=0, operstate=6
D/wpa_supplicant( 1330): nl80211: Set mode ifindex 22 iftype 2 (STATION)
D/wpa_supplicant( 1330): nl80211: Failed to set interface 22 to mode 2: -95 (Operation not supported on transport endpoint)
D/wpa_supplicant( 1330): nl80211: Try mode change after setting interface down
D/wpa_supplicant( 1330): nl80211: Set mode ifindex 22 iftype 2 (STATION)
D/wpa_supplicant( 1330): nl80211: Failed to set interface 22 to mode 2: -95 (Operation not supported on transport endpoint)
D/wpa_supplicant( 1330): nl80211: Interface mode change to 2 from 0 failed
E/wpa_supplicant( 1330): wlan0: Failed to initialize driver interface
D/wpa_supplicant( 1330): Failed to add interface wlan0
D/wpa_supplicant( 1330): wlan0: Cancelling scan request
D/wpa_supplicant( 1330): wlan0: P2P: Station mode scan operation not pending anymore (sta_scan_pending=0 p2p_cb_on_scan_complete=0)
D/wpa_supplicant( 1330): wlan0: Cancelling authentication timeout
D/wpa_supplicant( 1330): Get randomness: len=20 entropy=0
D/wpa_supplicant( 1330): random from os_get_random - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random from internal pool - hexdump(len=16): [REMOVED]
D/wpa_supplicant( 1330): random_mix_pool - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random from internal pool - hexdump(len=16): [REMOVED]
D/wpa_supplicant( 1330): mixed random - hexdump(len=20): [REMOVED]
D/wpa_supplicant( 1330): random: Updated entropy file /data/misc/wifi/entropy.bin (own_pool_ready=2)
I/wpa_supplicant( 1329): wpa_supplicant terminated by exit(255)
E/WifiHW  (  295): Supplicant not running, cannot connect
E/WifiHW  (  295): Supplicant not running, cannot connect
E/WifiHW  (  295): Supplicant not running, cannot connect
E/WifiHW  (  295): Supplicant not running, cannot connect
E/WifiHW  (  295): Supplicant not running, cannot connect
E/GeckoConsole( 1061): Content JS LOG at app://settings.gaiamobile.org/js/panels/mesh/panel.js:46 in wifiDisabled: wifiDisabled
E/GeckoConsole( 1061): Content JS LOG at app://settings.gaiamobile.org/js/panels/mesh/panel.js:88 in ctor_mesh/<._updateNetworkInfo: disconnected
(Reporter)

Comment 1

4 years ago
Created attachment 8486880 [details]
b2g-flame-ibss-failure.log
(Reporter)

Comment 2

4 years ago
Created attachment 8486881 [details]
b2g-flame-ibss-successful.log
(Reporter)

Comment 3

4 years ago
Looks like this is where things start to go wrong:

D/wpa_supplicant( 1330): nl80211: Failed to set interface 22 to mode 2: -95 (Operation not supported on transport endpoint)

Comment 4

4 years ago
What are you trying to do? I'm not sure adhoc/ibss is a well supported thing on modern phones. You'll want to look for p2p/Wifi Direct support which provides for better setup (device and service discovery) and power saving.
(Reporter)

Comment 5

4 years ago
The goal is to allow an easy path to create and join a public mesh network (LAN) using adhoc + olsr, specifically for places with no internet connectivity. In what sense is it not well supported? Is it a hardware limitation, or a driver issue?

Comment 6

4 years ago
Just a testing/support issue. It's less likely to be supported well because nearly everyone just uses infra mode. p2p/Wifi Direct does most common use cases for adhoc better. Mesh networking excluded.

You should try to change the mode of the interface before bringing the interface up. Drivers often get upset if you try to change the mode while the interface is up.
Depends on: 928362
See Also: → bug 1066709
(Reporter)

Comment 7

4 years ago
The aim here is to support mesh networking, so that would rule out WiDi.

I wonder if this is an issue with IBSS merge? Not sure how to test that.

Comment 8

4 years ago
Hi Youlong, would you help check this issue? Will include it into our tracking list. Tks.
Flags: needinfo?(youlong.jiang)

Comment 9

4 years ago
(In reply to Wesly Huang from comment #8)
> Hi Youlong, would you help check this issue? Will include it into our
> tracking list. Tks.

Dear wesly -

could you pls provide a reproduce step in detail. from previous comments, I didn't find anything accecable.

tks.
Flags: needinfo?(youlong.jiang)

Comment 10

4 years ago
Hi Alan:

Would you provide more for comment#9? I think vendor need to repro. it as well for analysis, thank you.

@Youlong, pls also check 1066709 for more information, tks.
Flags: needinfo?(akligman)

Comment 11

4 years ago
(In reply to Wesly Huang from comment #10)
> Hi Alan:
> 
> Would you provide more for comment#9? I think vendor need to repro. it as
> well for analysis, thank you.
> 
> @Youlong, pls also check 1066709 for more information, tks.

hi wesly -

I've checked related bug info, and found just patched and nothing for issue repro and check. then I think we need more details about this problem.

tks.

Comment 12

4 years ago
Hi Alan: per comment#11 would you help? Thank you.
(Reporter)

Updated

4 years ago
Flags: needinfo?(akligman)

Updated

4 years ago
Flags: needinfo?(alan.kligman)

Comment 13

4 years ago
You'll need to apply those patches to FxOS (except for the wpa_supplicant patch) and then enable Mesh in the settings panel. Let me know if you need help applying the patches.
Flags: needinfo?(alan.kligman)

Comment 14

4 years ago
Hi Youlong, would you follow Alan's suggestion above and let we know if help needed, thanks.
Flags: needinfo?(youlong.jiang)

Comment 15

4 years ago
(In reply to Wesly Huang from comment #14)
> Hi Youlong, would you follow Alan's suggestion above and let we know if help
> needed, thanks.

hi wesly -

after discuss with our engineer internally, I think we won't follow this kind of issue that not contained in our base images part. it would bring more workload to analysis gecko/gaia code. then sorry for refuse supporting.

tks.
Flags: needinfo?(youlong.jiang)

Comment 16

4 years ago
Hi Youlong:

As discussed I understood the potential effort if you need to port this function then investigate, and agree this is kinda out of scope we agreed in contract.

So like we said in phone would you focus on the error symptom/log, and provide your comment/suggestion about the error itself as a clue, based on your competence of low level BSP?

Thank you.
Flags: needinfo?(youlong.jiang)

Comment 17

4 years ago
(In reply to Wesly Huang from comment #16)
> Hi Youlong:
> 
> As discussed I understood the potential effort if you need to port this
> function then investigate, and agree this is kinda out of scope we agreed in
> contract.
> 
> So like we said in phone would you focus on the error symptom/log, and
> provide your comment/suggestion about the error itself as a clue, based on
> your competence of low level BSP?
> 
> Thank you.

hi wesly -

from log

D/SoftapController(  269): Softap fwReload - Ok
I/Gecko   (  295): WifiWorker::associateMesh
E/WifiHW  (  295): Unable to open connection to supplicant on "wlan0": No such file or directory

when reconnect wifi, firmware reload is ok. but can't find wlan0 device node, we doubt wifi driver crashed, but without clue why it happened. so we suggest you have a check on up-layer logic handle, matched with normal sequence.

tks.
Flags: needinfo?(youlong.jiang)

Comment 18

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.