Closed Bug 1065179 Opened 5 years ago Closed 5 years ago

[System] App authentication page is broken

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

It seems that we've broken the app authentication page by forgetting to port an instance of the <header> element in the system app.
[Blocking Requested - why for this release]: We can't ship with a broken authentication dialog.
blocking-b2g: --- → 2.1?
Whiteboard: [systemsfe]
Attached file Github pull request
Wilson - could you review this one? Thanks!
Attachment #8486856 - Flags: review?(wilsonpage)
Comment on attachment 8486856 [details] [review]
Github pull request

Code looks good. Thanks for spotting this Kevin, I knew there would be some parts in System I'd miss.
Attachment #8486856 - Flags: review?(wilsonpage) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/a004b664b88e49f3ffb84ae534578f3ee1211ef8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8486856 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Caused by gaia-header feature work.
[User impact] if declined: All authentication dialogs are broken.
[Testing completed]: Manual verification on a device.
[Risk to taking this patch] (and alternatives if risky): Low risk, it's already broken.
[String changes made]: None.
Attachment #8486856 - Flags: approval-gaia-v2.1?(fabrice)
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8486856 [details] [review]
Github pull request

surely not shipping with this one!
Attachment #8486856 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Alberto - could you help me review this one? Thanks!
Attachment #8507577 - Flags: review?(apastor)
Comment on attachment 8507577 [details] [review]
Pull request - add test case

Looks good to me. Small comment in GH. Thanks!
Attachment #8507577 - Flags: review?(apastor) → review+
(In reply to Alberto Pastor [:albertopq] from comment #9)
> Comment on attachment 8507577 [details] [review]
> Pull request - add test case
> 
> Looks good to me. Small comment in GH. Thanks!

I didn't see the comment, but let me know if there's anything else that needs a follow-up here and I will commit it. Thanks!

Test in master: https://github.com/mozilla-b2g/gaia/commit/dbe342b893204f4d097ff65535e85c7df8237def
Flags: in-testsuite+
Hi Kevin,

Could you please provide the detailed reproduce steps for me to verify this bug.
Thank you very much!
Flags: needinfo?(kgrandon)
You need to go to any webpage which requires authentication. To verify it just has to look ok and function. 

Perhaps clicking the "Display Image" link on this page might work? http://www.httpwatch.com/httpgallery/authentication/
Flags: needinfo?(kgrandon)
This issue has been verified successfully on Flame 2.1& 2.2.
 
1.Launch Browser and enter "http://www.httpwatch.com/httpgallery/authentication/".
2.Click "Display Image".

Actual result: An authentication request page is displayed.

See attachment: Verify_Video_Flame v2.1.MP4
Reproducing rate: 0/10

Flame v2.1 version:
Gaia-Rev        8ae086c39011bc8842b2a19bb5267906fa22345a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbd5c65c3c1
Build-ID        20141124094013
Version         34.0

Flame 2.2 version:
Gaia-Rev        aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/be4ba3d5ca9a
Build-ID        20141124100136
Version         36.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.