the "Create filter..." context menu item in address popup is enabled in the message pane when it shouldn't be

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

the "Create filter..." menu item is enabled in the message pane when it
shouldn't be.

for example, on messages in local folders.  there might be other examples.
Summary: the "Create filter..." menu item is enabled in the message pane when it shouldn't be → the "Create filter..." context menu item in address popup is enabled in the message pane when it shouldn't be

Updated

16 years ago
QA Contact: esther → laurel

Comment 1

16 years ago
Why is local folders off limits? Wouldn't we just open filters to the default
account? 
we figured out why this is happening.

we don't set the enabled / disable state properly unless the "Message" menu is
built.

varada's working on it.

as far as local folders, it's in the spec.
http://www.mozilla.org/mailnews/specs/filters/FilterPrefill1.html

but using the default account (assuming it supports filters) is a possibility.

jglick?

Comment 3

16 years ago
Sorry, I hadn't read down to the bottom/issues section in the spec.

Comment 4

16 years ago
If folks think associating it with the default account is useful, thats ok by 
me. It would make the feature available instead of disabling it.

What about news accounts then? Still disabled? 
> If folks think associating it with the default account is useful, thats ok by 
> me. It would make the feature available instead of disabling it.

I think that would be useful, given that most of the time the default account
supports filters.

> What about news accounts then? Still disabled? 

I'd say no, not until we support news filters.  (which will happen one day, I
swear!)

Updated

16 years ago
Keywords: nsbeta1

Comment 6

16 years ago
*** Bug 110162 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2

Comment 7

16 years ago
Just for the record, a recent change in behavior associated with this
enabled-when-shouldn't-be issue:

With current branch and trunk builds, we still have the header popup item
enabled for create filter. Now it does absolutely nothing, whereas in the branch
builds from last week (prior to fix) we brought up the filter rules dialog and
when filter was confirmed we'd add the filter to the Default mail account's
filter list. 

Comment 8

16 years ago
oops, the fix I talked about in comment #7 is bug 145091, which also addressed
some other filter related symptoms besides that described in 145091.

Comment 9

16 years ago
oops, the fix I talked about in comment #7 was for bug 140591, which also
addressed some other filter related symptoms.

Comment 10

16 years ago
nominating for next release
Keywords: nsbeta1- → nsbeta1
taking all of varada's bugs.
Assignee: varada → sspitzer

Comment 12

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

15 years ago
Keywords: nsbeta1

Comment 13

14 years ago
It doesn't appear there is anything left to do with this bug.  Messages in Local 
Folders *do* have this item disabled in the address context menu, and there is 
(limited) filter support in News so this works fine for that.

The URL for the spec listed in comment 2 is invalid, but this works:
  http://www.mozilla.org/mailnews/specs/filters/FilterPrefill.html

=>WFM; reset this if I'm wrong.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.