'Add' button is not localizable in FDN - Authorized Numbers

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: flod, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
In Settings -> Fixed dialing numbers -> Authorized numbers, the button "Add" is not localizable (issue is evident with pseudolocale).
(Assignee)

Comment 1

4 years ago
Turns out the string is marked for localization, but it was never exposed in the localization file.
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/elements/call_fdn_list.html#L6
Assignee: nobody → francesco.lodolo
(Assignee)

Comment 2

4 years ago
Created attachment 8487116 [details] [review]
Pull request on Github

Just adding the missing string in settings.en-US.properties
Attachment #8487116 - Flags: review?(arthur.chen)
Comment on attachment 8487116 [details] [review]
Pull request on Github

Nice catch! r=me
Attachment #8487116 - Flags: review?(arthur.chen) → review+
master: 16d5bbfc67ee79c897c373cda2689f42412382ad
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Reopening this bug because the issue is visible with the Arabic translation.

Build Information:
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: dd60c5be0a224ad103624dfc82d78a84f7314e27

Will attach a screenshot as well
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8682108 [details]
Screenshot of the bug using Arabic language setting
Delphine, could you take a look? looks like the old bug came back, so we reopened it.  Let us know whether it's better to open a new one.
Flags: needinfo?(lebedel.delphine)
Since a patch landed and the issue is still happening, please open a new bug for this issue
thanks!
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → FIXED

Updated

3 years ago
Blocks: 1221155
You need to log in before you can comment on or make changes to this bug.