If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser not rendering correctly. A black bar appears on the right with HWA enabled

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Kel, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

160.05 KB, image/jpeg
Details
(Reporter)

Description

3 years ago
Created attachment 8487192 [details]
example.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36 OPR/24.0.1558.53 (Edition Campaign 18)

Steps to reproduce:

I just launched the program as usual.  No updates happened prior to this issue arising.   I've attempted to uninstall and reinstall Firefox, but it didn't correct the problem.


Actual results:

A black bar appears on the right.  Browser buttons cannot be clicked on directly.  You have to click them off to the right side.  All menus and error message boxes appear with a distorted graphic to the right.

Comment 1

3 years ago
Are you using a special them in Firefox or in Windows 7?

Could you test with HWA disabled (restart Firefox to apply).
http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration

In addition, open about:support and copy the section "graphics" here.
Flags: needinfo?(moonlmysteries)
(Reporter)

Comment 2

3 years ago
There are no special themes used in Firefox or Windows.

I have disabled the HWA, and that fixed the problem.  Thanks!

Here is the information you requested.  I am copying this after I shut off the HWA, if that helps.

======

Adapter Description	Mobile Intel(R) HD Graphics
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0116
DirectWrite Enabled	false (6.2.9200.16492)
Driver Date	3-31-2011
Driver Version	8.813.1.0
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Mobile Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(moonlmysteries)

Comment 3

3 years ago
Ok, but disabling is only a "bad" workaround because HWA is useful to render the content and UI.
I see your Intel drivers are pretty old, could you try to update them if possible:
https://downloadcenter.intel.com/SearchResult.aspx?lang=&ProductID=3319&ProdId=3319 (verify they are compatible for your Intel HD Graphics).

Atfer that, renable HWA ad test again.
Component: Untriaged → Graphics
Product: Firefox → Core
Summary: Browser not rendering correctly. A black bar appears on the right → Browser not rendering correctly. A black bar appears on the right with HWA enabled
(Reporter)

Comment 4

3 years ago
I have updated the drivers and renabled the HWA.  The browser seems to be running smoothly.  

Thank you,

Comment 5

3 years ago
Just for the record, could you paste here the new "graphics" section in about:support (it could help in the future).
(Reporter)

Comment 6

3 years ago
Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0116
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16492)
Driver Date	3-20-2014
Driver Version	9.17.10.3517
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

Comment 7

3 years ago
Thanks, your GPU is better identified now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.