ATT FF Custom Build Home Page Set

RESOLVED FIXED

Status

Release Engineering
Releases: Custom Builds
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Jonathan Lee, Assigned: mconnor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.103 Safari/537.36

Steps to reproduce:

Typically what we’ve done in the past is follow the process described here: https://wiki.mozilla.org/Partnering/Repacks/Submitting_Changes
We’ve done the same thing with the ATT repack this time around, but with the difference that the patch we’ve submitted to you is a brand new config (I.e. a new directory under the partner-repacks directory - https://hg.mozilla.org/build/partner-repacks), unlike the patches we’ve submitted in the past that have been changes to existing configs (I may be using incorrect nomenclature here, I hope I’m making myself understood).



Actual results:

With this AT&T FF custom build, we need the home page set to att.net which is a Yahoo hosted front page for AT&T and search set to the following URL

https://search.yahoo.com/yhs/search?p=Address+bar+search&fr=attportal-yff32-yhs&hspart=att&hsimp=yhs-att_001&type=att_yff32_address_bar

Currently it's not setting to the above homepage.


Expected results:

The AT&T subset of the Yahoo! audience have a different homepage setting for their browsers.

Could we establish a different release configuration for this targeting?

Comment 1

3 years ago
Created attachment 8487316 [details] [diff] [review]
repack_config_changes_for_yahoo.diff.3

Proposed config for ATT repack

Updated

3 years ago
Component: Untriaged → Releases: Custom Builds
Flags: needinfo?(mconnor)
Product: Firefox → Release Engineering
QA Contact: coop
(Assignee)

Comment 2

3 years ago
Abhinav, I have enough to review if the other bits are all unchanged from en-US, however this patch won't have the toolbar, etc, as it stands.  You may need to hg add all of those files and regenerate the diff.  Also, if you're using Mercurial Queues, can you use hg qfold to collapse these csets into a single cset for landing?
Flags: needinfo?(mconnor)

Comment 3

3 years ago
Yes, Jonathan and Mason decided that this build should *not* have the toolbar shipped with it. 
I will have a look at hg qfold. Thanks.
(Assignee)

Comment 4

3 years ago
Okay, I'm going to take a different path and generate a clean config that should get you the right outcome.  Give me a couple of hours to pull that together.
(Assignee)

Updated

3 years ago
Assignee: nobody → mconnor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 5

3 years ago
(In reply to Jonathan Lee from comment #0)
> Actual results:
> 
> With this AT&T FF custom build, we need the home page set to att.net which
> is a Yahoo hosted front page for AT&T and search set to the following URL
> 
> https://search.yahoo.com/yhs/search?p=Address+bar+search&fr=attportal-yff32-
> yhs&hspart=att&hsimp=yhs-att_001&type=att_yff32_address_bar
> 
> Currently it's not setting to the above homepage.

Jonathan, can you explain desired/expected results for the type parameter?  It's a little confusing to have something like "type" be hardcoded to say all searches are from the address bar.

I know hspart and hsimp are YHS parameters, I'll make sure those are implemented correctly.
(Assignee)

Comment 6

3 years ago
I've been cleaning up out of date overrides, since some of them are doing strange things (like adding back in services we've dropped from core)

One thing to note is that startup.homepage_welcome_url="https://downloads.yahoo.com/firefox/welcome" is probably not necessary or desirable here, since there's no toolbar.  Thoughts?

Comment 7

3 years ago
https://search.yahoo.com/yhs/search?p=Address+bar+search&fr=attportal-yff32-yhs&hspart=att&hsimp=yhs-att_001&type=att_yff32_address_bar

This YHS URL is the default Yahoo search URL for the address bar / omnibox. The intention of type is to denote for Yahoo backend system that this search comes from ATT FF32 address bar. Going forward we are moving to consolidate to hsimp. 

We will get back to you on startup.homepage_welcome_url
(Assignee)

Comment 8

3 years ago
Mason, we have five distinct access points (search bar, address bar, about:home (less relevant here), right click, and new tab).  If we want to distinguish just ATT FF32, could we shorten that to att_yff32.  Note that we don't have an omnibox like Chrome.

Comment 9

3 years ago
Ok to shorten to att_yff32 thanks.

https://search.yahoo.com/yhs/search?p=Address+bar+search&fr=attportal-yff32-yhs&hspart=att&hsimp=yhs-att_001&type=att_yff32
(Assignee)

Comment 10

3 years ago
Created attachment 8488764 [details] [diff] [review]
cleaned up patch for new config.

Cleaned up config, removed prefs that were unnecessary or duplicated existing defaults, updated Persona data to current, made sure the right params were all present in the search plugin (based on the current shipping en-US version of the Yahoo plugin), and set this build for Windows only (since that's my understanding of the targeting here).  This is tested against 32, with the only open question what to do about first-run page (I'm not sure we even need one).

Abhinav, please test and review.
Attachment #8487316 - Attachment is obsolete: true
Flags: needinfo?(abhinavn)

Comment 11

3 years ago
Regarding the startup.homepage_welcome_url page, this can be set to att.net
(Assignee)

Comment 12

3 years ago
Mason, I don't think that's what you want, because the homepage will already be att.net, so you'll get two tabs with the same content.  Mostly it just seems broken if you duplicate things.

Comment 13

3 years ago
Ok, I will test the download to see the exact experience. I thought to show the att.net page post installation. But sounds like the new tab page shows post installation so there is a duplicate. If so then perhaps no need for welcome url page.
(Assignee)

Comment 14

3 years ago
For clarity, the default homepage is already set att.net, and the "welcome_url" pref opens a second tab to that value, so you'd get duplicate tabs.  I'll get this landed and test builds created.

Comment 15

3 years ago
Ok to remove the welcome url so no second / duplicate tab.

Comment 16

3 years ago
Hi Mike,

I'm not sure how to test the diff you've given. Should I wait for the test build, or is there a way I can use this diff to modify my Firefox installation perhaps?
Flags: needinfo?(abhinavn) → needinfo?(mconnor)

Comment 17

3 years ago
OK I've done a super quick verification of your patch, Mike, by 'hg import'-ing into my repo, and copying the contents of the distribution directory to my Firefox installation's distribution directory (too hacky?). I'm waiting for Mason's go ahead but everything looks green from my quick eyeballing.
(Assignee)

Comment 18

3 years ago
Abhinav: that's pretty much exactly what the repacks do, in terms of final effect, and how I tested.  (Keep in mind that the system dates back to when we still had .zip builds as a supported option!)

https://hg.mozilla.org/build/partner-repacks/rev/fb9fe892a881 is landed, filed bug 1068045 to produce builds.  Once Yahoo has signed off, we can closed this bug.
Flags: needinfo?(mconnor)
(Assignee)

Comment 19

3 years ago
http://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/32.0.1-candidates/build2/partner-repacks-bug1068045/yahoo-en-US_att/win32/en-US/Firefox%20Setup%2032.0.1.exe is the build for testing, already notified via email.  Waiting on final confirmation before closing.

Comment 20

3 years ago
Uninstalled previous FF32 on win7pro. Installed this build 32.0.1. Yahoo search set defaults to the ATT YHS URL with fr=attportal-yff32-yhs. Home page is pointing to https://www.yahoo.com/?ilc=302&fr=yset-ff-hp instead of att.net.

Comment 21

3 years ago
Uninstalled FF. Manually deleted the profile. Installed build 32.0.1. Now able to get home page to att.net.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.