If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent test_preload_actions.html | application crashed [@ PR_GetThreadPrivate][@ mozilla::BlockingResourceBase::Release()]

RESOLVED DUPLICATE of bug 1089072

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1089072
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=47755838&tree=Mozilla-Inbound

Android 4.0 Panda mozilla-inbound debug test mochitest-3 on 2014-09-09 22:58:28 PDT for push 5be24e2c319c
slave: panda-0200

23:26:33     INFO -  235 INFO TEST-START | /tests/content/media/test/test_preload_actions.html
23:26:33     INFO -  INFO | automation.py | Application ran for: 0:17:05.777711
23:26:33     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpF8hzPjpidlog
23:26:33     INFO -  Contents of /data/anr/traces.txt:
23:26:36     INFO -  mozcrash Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-debug/1410327193/fennec-35.0a1.en-US.android-arm.crashreporter-symbols.zip
23:26:40     INFO -  mozcrash Saved minidump as /builds/panda-0200/test/build/blobber_upload_dir/7acea7a3-2090-0613-64930e85-7d94b6ec.dmp
23:26:40     INFO -  mozcrash Saved app info as /builds/panda-0200/test/build/blobber_upload_dir/7acea7a3-2090-0613-64930e85-7d94b6ec.extra
23:26:40  WARNING -  PROCESS-CRASH | /tests/content/media/test/test_preload_actions.html | application crashed [@ PR_GetThreadPrivate]
23:26:40     INFO -  Crash dump filename: /tmp/tmpl9EIov/7acea7a3-2090-0613-64930e85-7d94b6ec.dmp
23:26:40     INFO -  Operating system: Android
23:26:40     INFO -                    0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
23:26:40     INFO -  CPU: arm
23:26:40     INFO -       2 CPUs
23:26:40     INFO -  Crash reason:  SIGSEGV
23:26:40     INFO -  Crash address: 0xece
23:26:40     INFO -  Thread 66 (crashed)
23:26:40     INFO -   0  libnss3.so!PR_GetThreadPrivate [prtpd.c:5be24e2c319c : 205 + 0x0]
23:26:40     INFO -       r4 = 0x00000002    r5 = 0x6bd2ba64    r6 = 0x6c15fd8c    r7 = 0x6c15fd84
23:26:40     INFO -       r8 = 0x6c15fd94    r9 = 0x00000000   r10 = 0x6bd2ba64    fp = 0x00146f4d
23:26:40     INFO -       sp = 0x6c15fd38    lr = 0x60420c55    pc = 0x604221cc
23:26:40     INFO -      Found by: given as instruction pointer in context
23:26:40     INFO -   1  libxul.so!mozilla::BlockingResourceBase::Release() [BlockingResourceBase.cpp:5be24e2c319c : 341 + 0x3]
23:26:40     INFO -       r4 = 0x6bd2ba64    r5 = 0x6bd2ba64    r6 = 0x6c15fd8c    r7 = 0x6c15fd84
23:26:40     INFO -       r8 = 0x6c15fd94    r9 = 0x00000000   r10 = 0x6bd2ba64    fp = 0x00146f4d
23:26:40     INFO -       sp = 0x6c15fd40    pc = 0x62acfd6d
23:26:40     INFO -      Found by: call frame info
23:26:40     INFO -   2  libxul.so!mozilla::ReentrantMonitor::Exit() [BlockingResourceBase.cpp:5be24e2c319c : 440 + 0x3]
23:26:40     INFO -       r4 = 0x6bd2ba64    r5 = 0x00000001    r6 = 0x6c15fd8c    r7 = 0x6c15fd84
23:26:40     INFO -       r8 = 0x6c15fd94    r9 = 0x00000000   r10 = 0x6bd2ba64    fp = 0x00146f4d
23:26:40     INFO -       sp = 0x6c15fd58    pc = 0x62acfe9d
23:26:40     INFO -      Found by: call frame info
23:26:40     INFO -   3  libxul.so!mozilla::ReentrantMonitorAutoEnter::~ReentrantMonitorAutoEnter() [ReentrantMonitor.h:5be24e2c319c : 185 + 0x5]
23:26:40     INFO -       r4 = 0x6c15fd90    r5 = 0x00000001    r6 = 0x6c15fd8c    r7 = 0x6c15fd84
23:26:40     INFO -       r8 = 0x6c15fd94    r9 = 0x00000000   r10 = 0x6bd2ba64    fp = 0x00146f4d
23:26:40     INFO -       sp = 0x6c15fd68    pc = 0x62aac4a3
23:26:40     INFO -      Found by: call frame info
23:26:40     INFO -   4  libxul.so!nsThreadPool::Run() [nsThreadPool.cpp:5be24e2c319c : 216 + 0x5]
23:26:40     INFO -       r4 = 0x6bd2ba50    r5 = 0x00000001    r6 = 0x6c15fd8c    r7 = 0x6c15fd84
23:26:40     INFO -       r8 = 0x6c15fd94    r9 = 0x00000000   r10 = 0x6bd2ba64    fp = 0x00146f4d
23:26:40     INFO -       sp = 0x6c15fd70    pc = 0x62ac252d
23:26:40     INFO -      Found by: call frame info
23:26:40     INFO -   5  libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:5be24e2c319c : 823 + 0xb]
23:26:40     INFO -       r4 = 0x6d05d814    r5 = 0x00000000    r6 = 0x6d05d7d0    r7 = 0x6c15fdf0
23:26:40     INFO -       r8 = 0x6c15fde4    r9 = 0x00000000   r10 = 0x00000000    fp = 0x6c15fe2f
23:26:40     INFO -       sp = 0x6c15fdc0    pc = 0x62ac1873
23:26:40     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: crash, intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1089072
You need to log in before you can comment on or make changes to this bug.