Result sets containing no jobs only appear in the UI after a page reload

RESOLVED FIXED

Status

Tree Management
Treeherder
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Assigned: jeads)

Tracking

Details

(Reporter)

Description

3 years ago
Broken out from bug 1048043.

There are several scenarios where a result set (push) may have no jobs associated with it:
1) The push was only recently made, and buildbot hasn't yet scheduled a job (ie: this is hit when people click the treeherder try link from the hg output after they push).
2) The push was made with "DONTBUILD" in the topmost commit message (used to save resources if the change was believed to not affect the build, eg a type fix in a comment).
3) If two pushes are made within 60 seconds of each other, the buildbot hg poller may only see one unit of change (since it polls only every 60s) and so jobs are only scheduled on the later push.

This is a problem, since currently socket.io notifications are only sent when new jobs are ingested, not when the result set itself is ingested. 

As such:
a) For #1 above, this increases the delay before a result set shows up, since we have to wait for the first job.
b) For #2 or #3, the new result set does not appear in UI until the page is reloaded.

Due to the impact of (b) on sheriffing, this is a blocker (ie: pushes can be hidden from view when tabs for inbound/fx-team/... are kept open and not force refreshed).
(Reporter)

Comment 1

3 years ago
The root cause of this bug is that we don't have notifications at the result set (push) level, only the job level (and the pushes come for free along with the jobs).

This might be fixed by bug 1067420, depending on the approach taken there.
Depends on: 1067420
(Assignee)

Updated

3 years ago
Assignee: nobody → jeads
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
This was fixed in https://github.com/mozilla/treeherder-ui/pull/190
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.