Frequently recurring dialog provides almost no useful diagnostic information

RESOLVED FIXED

Status

Calendar
Provider: GData
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Oz, in DFW, Assigned: Fallen)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

The problem is that the error dialog appears every minute or so and disrupts all activity, cannot be disabled, and provides no diagnostic information. 

This bug *appears* to relate to calendar entries that Google Calendar does not understand.

This may be related to the Google calendar provider, but Thunderbird/Lightning turns an annoyance into a disruption every minute. 


Actual results:

I get a popup dialog once a minute or so:

     "An error occurred when writing to the calendar Google Cal!"

If I click on the "Details"  button I get 

     "MODIFICATION FAILED" and the Description field is blank

The last few error console entries prior to the message are:

[JavaScript Warning: "There has been an error reading data for calendar: Google Cal.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80040111. Description: A request Error Occurred. Status Code: 400 Bad Request Body: Illegal gd:reminder method or time  specified: -1 seconds"]

[JavaScript Warning: "[calCachedCalendar] Unable to perform playback action modify to the server, will try again next time (null,A request Error Occurred. Status Code: 400 Bad Request Body: Illegal gd:reminder method or time  specified: -1 seconds)"]

[JavaScript Warning: "There has been an error reading data for calendar: Google Cal.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80040111. Description: A request Error Occurred. Status Code: 400 Bad Request Body: Illegal gd:reminder method or time  specified: -1 seconds"]

[JavaScript Warning: "[calCachedCalendar] Unable to perform playback action modify to the server, will try again next time (null,A request Error Occurred. Status Code: 400 Bad Request Body: Illegal gd:reminder method or time  specified: -1 seconds)"]



Expected results:

I would expect some information that allowed me to act on and diagnose the problem. As a minimum, providing the calendar item title so that I can find it and review or delete it. Ideally, a dump or some summary of the command that lead to the error message. 


I have seen this several times in the last few weeks.   It seems to be the result of calendar entry, but I can't tell which one. It *seems* to go away once the event is in the past, but it's hard to tell because I can;t tell which entry is causing the problem. .

Updated

3 years ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 31 → unspecified

Comment 1

3 years ago
What version of the Provider for Google Calendar extension do you use?
Does turning off the offline support / cache for the calendar helps?
Component: General → Provider: GData
(Reporter)

Comment 2

3 years ago
I may have found the source of the problem that caused the information starved dialog. Enabling and disabling offline support caused a (single) calendar reminder to pop up for snooze or dismissal AND seemed to cause the dialog to appear.  the reminder was for a calendar entry with multiple reminders set, one of which was  "25316 minutes after the events starts." Removing that reminder seems to have stopped the recurring dialog.

This does not, however, fix what I feel is the real bug - a dialog with little useful diagnostic information. 

To respond to the initial request for information, the versions of calendar related extensions:

	Lightning 3.3 last updated 22 AUG 2014

	Lightning Nightly Updater (Unofficial) 0.11.110714 last updated 18 JUN 2012

	Provider for Google Calendar 0.32 last updated 27 AUG 2014

I also have these extensions installed: 

	Enigmail 1.7.2
	LookOut 1.2.13
	Sync Kolab 3.1.4
	Windows Contacts Loader 0.3.8
	Folderpane Tools 0.6.1

After Thunderbird startup I'm also seeing a dialog that says:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://calendar/content/calendar-unifinder.js:898" and gives me  a check box option of 'don't ask me again' and button options of 'continue' or 'stop script.'

I'm not sure if this is part of this issue, or should be identified as a separate issue. Removal of the reminder entry that quieted the other error dialog has not caused this to go away at startup. 

And - thanks for all your help.
(Reporter)

Comment 3

3 years ago
Adding a reminder due a large number of minutes (I tried 25000) after the event seems to reliably reproduce the dialog. What does not happen is storing of the reminder on Google cal.  

I suspect what has happened is that the original reminder was somehow corrupted and stored locally or in Google Cal resulting in the reminder for tens of thousands of minutes after the event. That, in turn caused the dialog.

Comment 4

3 years ago
From what I read recently on another bug (sorry, I actually don't have the refernce at hand), Google does not accept custom reminders but expects only those which are also configurable via web interface. Does the problem go away, if you use one of those?
(Assignee)

Comment 5

3 years ago
This should be fixed in 1.0.x, or at least the dialog should not allow you to create such alarms.
Assignee: nobody → philipp
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.