Position of reload button can no longer be customised

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: scratch65535, Unassigned)

Tracking

32 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

I tried to move the reload button over to the left, by the back button, where I had it in previous versions.


Actual results:

I couldn't.  It and the url edit box now appear to be inseparable.


Expected results:

I should have been able to move it over to the left side, as I could in the past.  

It's annoying to click 'back' and then have to move the mouse almost all the way across the screen and then fumble around to get to the small reload button.  The code was already written and in place for several versions, so it's not clear why it was changed, if the change was intentional.

Comment 1

3 years ago
It's by design, the Australis theme.
Use this add-on to retrieve the previous theme:
https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
It's *very* bad human-factors practice to eliminate functionality.  

If there's some supposed benefit to such a change then it should be offered rather than imposed.  No one should have to do additional work to restore functionality.  Cosmetic changes are usually just that: cosmetic, like changes in retail packaging, and they definitely never provide any benefit that could justify eliminating functionality.

Thanks for telling me about this add-on.  It doesn't really restore the earlier interface, it only patches the current one.  But it restores the functionality I want, albeit in a crude way, so I'm happy to use it.

I'd suggest for future revisions not only that the toolbars be fully customisable again, but that the tab bar be moved back down below the bookmark bar to visually reconnect with the viewport, as it was in an earlier version (I don't remember which).  Moving them up was a case of a cosmetic change that directly reduced usability: the psychological principle involved is that we expect things that are related to be close together, so when they're not it costs us a few clocks extra each time to figure out what's going on.
You need to log in before you can comment on or make changes to this bug.