Closed Bug 1065658 Opened 5 years ago Closed 5 years ago

Rocketbar can close unexpectedly

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

It's rare, but I think right now the rocketbar can close while you're using it if something opens up in the background.
Attached file Github pull request
Tim or Etienne - I am trying to save Alive some review time, either of you guys have time to review this? Thanks!
Attachment #8487514 - Flags: review?(timdream)
Attachment #8487514 - Flags: review?(etienne)
Comment on attachment 8487514 [details] [review]
Github pull request

I can't review this -- I am not familiar with this part enough.
Attachment #8487514 - Flags: review?(timdream)
Comment on attachment 8487514 [details] [review]
Github pull request

Alive - could you take a look when you get a chance? Thanks!
Attachment #8487514 - Flags: review?(alive)
Comment on attachment 8487514 [details] [review]
Github pull request

Makes sense but please only check evt.detail.stayBackground in launchapp handler otherwise you will keep opened when receiving appopened event from a system-message launched app.
Attachment #8487514 - Flags: review?(etienne)
Attachment #8487514 - Flags: review?(alive)
Comment on attachment 8487514 [details] [review]
Github pull request

Hey Alive - Updated it. I feel that even if app window injects a stayBackground that we would want to keep the search app open, but maybe I'm not familiar with all the cases. In any case, seems like this should be fine for now. Thanks!
Attachment #8487514 - Flags: review?(alive)
Comment on attachment 8487514 [details] [review]
Github pull request

Maybe this is an UX question, but some system message launched app will use mozApps to launch itself. I think we should do something to let the user know there is such an app opened. Now closing search window is the fastest way to go, but if UX has better idea we could implement in followup.
Attachment #8487514 - Flags: review?(alive) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/37094ec8a89f3a330984d44fb4c74d340e23cf0e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8487514 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature work.
[User impact] if declined: The search app will sometimes close unexpectedly, and this is pretty rare.
[Testing completed]: Manual and unit tests.
[Risk to taking this patch] (and alternatives if risky): Low risk as it's a small patch and contained within the search app.
[String changes made]: None.
Attachment #8487514 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8487514 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.