Closed Bug 1065731 Opened 6 years ago Closed 5 years ago

When adding a number to an existing contact, search icon does nothing

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: dietrich, Assigned: jmcf)

Details

(Keywords: regression)

Attachments

(2 files)

Flame, nightly OTA channel (master + mozilla-central), Sept 10.

STR:

1. receive text from a number not in your contacts
2. click on number
3. choose "Add to an existing contact"
4. click the search icon
5. click it a bunch more times

Expected: able to search

Actual: only once in at least 20 times did it show me the search UI.
QA Wanted for branch checks.
Keywords: qawanted
Unable to repro on KK Flame 2.2 and Flame 2.1.
Actual result: Tapping the search icon next to the search textbox brings up the search interface.
Leaving qawanted tag for another tester to attempt.

Flame 2.2
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Platform Version: 35.0a1
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140910165554
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Platform Version: 34.0a2
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
Dietrich, 

I added a video shows that when the user taps on the "search" icon, the search symbol appears, but user is not taken to the search page.  Does my video illustrate the issue you are seeing?  Also, are you seeing this with the JB or KK base on your device?  Thanks!

Video link: https://www.youtube.com/watch?v=7hJshCPkKwM&feature=youtu.be

Device: Flame Master
BuildID: 20140910165554
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (Master) 
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(dietrich)
What I see from the video is that what is being press is the quick scroll action from the search, that will scroll you to the top, if you are already in the top, won't do anything.
Yep, the video shows what I saw. Thanks Duane! I'm using the JB base.

Francisco, I'm not sure what you mean. I was touching the search icon. Where is the quick scroll action?
Flags: needinfo?(dietrich)
Hi folks,

I'll try to explain myself a bit better, sorry for the lack of message in previous comment ;P

Would like to point out something that you see on the video, when you press on the icon search, you could see how a big icon search appears, later a big star appears. 

That's a sign that the search icon was not being pressed, instead, what was being receiving the touch action is what we call the 'contacts shortcuts', that is the list off all letters on the right (+ search and favorites), that's used to quick scroll to any part of the app, from letters, to scroll back to the search or favorites area.

So when you are already on the top of the page and you touch on the contacts shortcuts (it's easy to spot since you'll see a big letter or search or favorites) appearing, the screen won't be affected.
Thanks Francisco! So what's the fix? The fact that the search icon is expected to be press-able, but isn't, is pretty broken.
Carrie, would you mind to help us here.

My only concern is that we did the touchable area around the quick scroll bigger for making it more usable, now seems it's way to bigger and people would have difficulties to touch the search icon (you must be super precise).
Flags: needinfo?(cawang)
Yes, I think we can either adjust the touch area or move the "search" icon to the left. I need to discuss with other UX to see if it's a system behavior.
Keep the ni? here. I'll update to you guys later. Thanks!
I've discussed this with Fang and we'd suggest either removing the "search" icon in the search field or moving it to the left. We're waiting for the feedback from framework team since this will be a system change. ni? Harly for the decision making. Thanks!
Flags: needinfo?(cawang) → needinfo?(hhsu)
I have discussed with the Framework team today, and the team pointed out that we will have a search field web component in 2.2 for each app to apply, and will fix the "search" icon issue as well. Thanks!
Flags: needinfo?(hhsu)
(In reply to Jason Smith [:jsmith] from comment #1)
> QA Wanted for branch checks.

Issue is reproducible on Flame 2.2, Flame 2.1, Flame 2.0, and base image v180 only (v2.0).

Observed behavior: Tapping on the magnifying glass icon (search icon) on the right of the Contacts app triggers the quick scrolling functionality instead of search functionality. Tapping to the left of the search icon correctly brings up the search window.

Device: Flame (shallow flash)
BuildID: 20141007130518
Gaia: 9050edcda308b65d86577c8ed0eedc5c568d8e44
Gecko: 0c8ae792f1c0
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame (shallow flash)
BuildID: 20141007075118
Gaia: da328c6cbabf2cffc2d362e282cacc93325d1f43
Gecko: aebe54593d60
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20141007065153
Gaia: 31a49c7932c7085961760a6bef9ed381ea38d7e3
Gecko: 390acb9d220d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
[Blocking Requested - why for this release]:

Tier 1 device functionality, which is basically unusable. I can tap the icon 20 times and never get to the search feature to activate.

If we don't fix it now and backport, downstream partners will find the regression and require a fix. And then the tech press reviewers will find it. And then our users will find it.

The only reason I can think of to not block is if the bug specific to Flame. In which case it still needs a fix or backout asap.

Francisco, any idea what regressed this, and whether we have a regression test on this functionality?
blocking-b2g: --- → 2.0?
Flags: needinfo?(francisco)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Hi Harly & Carrie, 
We need a solution asap for fixing in master (currently 2.2), and likely need to backport (to 2.0, 2.1) per comment 13. Please help.
Flags: needinfo?(hhsu)
Flags: needinfo?(cawang)
Triage: regression issue,  set it to 2.0+.
blocking-b2g: 2.0? → 2.0+
Hi, 

OK, We decided to remove the search icon from the search field in Contacts APP. By doing this, at lease users will not tap the icon on the right and expect to trigger search function. Instead, they will tap the "search" text on the left. This will be a temporary solution. We'll provide an system-wise design during common component implementation. Thanks!
Flags: needinfo?(hhsu)
Flags: needinfo?(cawang)
Now that we have a final solution from Carrie, we can fix this in 2.2 and ask to be uplift to 2.0 and 2.1

Cheers,
Flags: needinfo?(francisco)
Target Milestone: --- → 2.1 S7 (Oct24)
Assignee: nobody → jmcf
Attached file 25136.html
Attachment #8504736 - Flags: review?(francisco)
Comment on attachment 8504736 [details]
25136.html

LGTM, left a tiny message in github.
Attachment #8504736 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/commit/0a56bca14e743a5d1b34808cbaffc171f845de60
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request Gaia v2.0 and v2.1 approval on this when you get a chance :)
Flags: needinfo?(jmcf)
Comment on attachment 8504736 [details]
25136.html

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bad positioning of UI elements. 
[User impact] if declined: Medium. Inconsistent UI
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Very-low risk
[String changes made]:
Flags: needinfo?(jmcf)
Attachment #8504736 - Flags: approval-gaia-v2.0?
Comment on attachment 8504736 [details]
25136.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bad positioning of UI elements
[User impact] if declined: Medium. inconsistent UI
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]:
Attachment #8504736 - Flags: approval-gaia-v2.1?
Attachment #8504736 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Comment on attachment 8504736 [details]
25136.html

Requesting qa verification once this lands on 2.0.
Attachment #8504736 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Keywords: verifyme
This issue still reproduces on Flame 2.0, Flame 2.1, and Flame 2.2

Actual Results: Magnifying glass icon still exists to right of search bar when adding number from sms message to existing contact. Pressing on or near search bar brings up larger magnifying glass icon but does not select search field.

Device: Flame 2.0  (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141024000201
Gaia: 86d83f4b4111ca45ebc92ca779348cc966f43cff
Gecko: f8432250efb7
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame Master (319mb)(KitKat Base)(FullFlash)
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
(In reply to Brogan Zumwalt [:BroganZ] from comment #27)
> This issue still reproduces on Flame 2.0, Flame 2.1, and Flame 2.2
> 
> Actual Results: Magnifying glass icon still exists to right of search bar
> when adding number from sms message to existing contact. Pressing on or near
> search bar brings up larger magnifying glass icon but does not select search
> field.

What you are requesting is a new feature. The search button icon has never make it to focus the search field. It allows you to scroll to the search field but the focus has to be positioned but the user. So I think this bug should be marked as verified. 

If you think the search box should be focused, then please file another bug and we will discuss it with UX as a new feature.

thanks
Flags: needinfo?(ktucker)
Flags: needinfo?(bzumwalt)
Verified fixed on Flame 2.0, Flame 2.1, and Flame 2.2

Actual Results: UI is correct as per comment 28

Environmental Variables: See comment 27
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(bzumwalt)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
    Verify passed, this issue can't be repro on Woodduck 2.0.
Attached: Verify_Woodduck_Searchcontact.mp4
Reproducing rate: 0/10
Gaia-Rev        ee5cf148b4c546beea9bfb799d2a3ee62074957d
Gecko-Rev       73601b71861cbc2f180c4d2653cec3e9fbb39db5
Build-ID        20141114050313
Version         32.0
You need to log in before you can comment on or make changes to this bug.