If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[NFC] Gallery force closes everytime the user tries to share a photo

RESOLVED WORKSFORME

Status

Firefox OS
NFC
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

(Blocks: 2 bugs, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-flame-test-run-2], URL)

Attachments

(1 attachment)

Created attachment 8487574 [details]
NFCGalleryLog.txt

Description:
Everytime the user tries to share a photo using NFC, the gallery app will force close and no photo will be shared. 

Prerequisite:
Turn on NFC on both test devices.

Repro Steps:
1)  Updated Flame to Build ID: 20140910000202
2)  Tap the gallery app to open it on Device A.
3)  Tap on a photo on Device A.
4)  Tap Device A to Device B and swipe up on the photo on Device A to share it.

Actual:
Photo is not shared and the gallery app will force close.

Expected:
The photo is shared without issue. The gallery app does not force close. 

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202 (319mb) 
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/10581/
See attached: video clip, logcat
This issue does not occur on the Flame 2.2(319mb), Flame 2.1(512mb) and the Flame 2.0(319mb).

The picture is shared without issue and the gallery app does not force close. 

Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202 (512mb) 
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-----------------------------------------------------------------------------------------

This issue does not occur on the Open C 2.2, Open C 2.1 and Open C 2.0 because the phone is not NFC capable. 

Open C 2.2

Environmental Variables:
Device: Open_C Master
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140910000202
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open_C 2.0

Enviromental Variables:
Device: Open_C 2.0
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-----------------------------------------------------------------------------

This issue does not occur on the Flame 1.4 because NFC was not supported.

Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
BuildID: 20140910000204
Gaia: 6018a1c18f0c3eab25aac2ba3064904740591dd2
Gecko: 90e68c490bf9
Version: 30.0 (1.4) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Please note that the full flash script was used for the Flame 2.1(319mb) that this issue was encountered on. The flash script does not matter since this issue also occurs when using the shallow flash as well.
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(dharris)
(Reporter)

Updated

3 years ago
Blocks: 933640
[Blocking Requested - why for this release]:

nominating this as a 2.1? blocker. The user should be able to share photos via nfc. plus this is a regression
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
I was unable to reproduce this issue on the reporter's build or any others.  Leaving the QA wanted tags for another to give it a shot.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(jmitchell)
triage: we should block on this. if it can't be reproduce anymore, we can set RESOLVED WORKSFORME then
Blocks: 1039181
blocking-b2g: 2.1? → 2.1+
Swapping window for QA-Wanted to see if we can reproduce in 2.1
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted → qawanted
Unable to repro on the latest KK Flame 2.1
Actual result: Gallery photos can be transferred to other devices via NFC with no errors.

BuildID: 20140923073140
Gaia: 1e554253d11b0cc932de39c0a4510d1abb176550
Gecko: ee9dbbb02910
Platform Version: 34.0a2
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Setting NI to Kevin Tucker to look into this further.
Flags: needinfo?(ktucker)
I was unable to reproduce this issue on the Flame KK base with a 2.1 Nightly build. 

Repro attempts: 0/10

Environmental Variables:
Device: Flame 2.1
Build ID: 20140924063013
Gaia: 020e6283a033e8fbcf65e7ed81c5b75ba0095f22
Gecko: d6b762814638
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Resolving per comment 4
Status: NEW → RESOLVED
blocking-b2g: 2.1+ → ---
Last Resolved: 3 years ago
Flags: needinfo?(ktucker)
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.