[Homescreen] Unable to edit the URL of bookmarks

RESOLVED INVALID

Status

Firefox OS
Gaia::Homescreen
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: SMiko, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-2])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8487597 [details]
bookmark.png

Description:
The user is unable to edit the web address of a bookmark added to the home screen.

Repro Steps:
1: Update a Flame to 20140910000202
2: Search for a website using the rocketbar or browser
3: Tap on the (...) on the top right of the screen
4: Select "Add to home screen"

Actual:
The only feature that can be edited is the name of the bookmark

Expected:
Both the name and address of the bookmark can be edited.

Notes:
1: This issue also occurs when editing a bookmark from the home screen

Flame 2.1(319mb)

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140910000202
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%

Link to failed test case: https://moztrap.mozilla.org/manage/case/11855/

See attached: screenshot
(Reporter)

Comment 1

3 years ago
Created attachment 8487599 [details]
logcat

This issue DOES repro on Flame 2.2(319mb), Open C 2.2, Flame 2.1(512mb), and Open C 2.1

Actual Result: The option to edit the URL of bookmarks does not exist.

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C Master
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202 (512mb) 
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
BuildID: 20140910000202
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


This issue does NOT repro on Flame 2.0(319mb), or Open C 2.0

Actual Result: The option to edit the URL of bookmarks exists

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Enviromental Variables:
Device: Open_C 2.0
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.1-flame-test-run-2]
I think this is working as designed - ni on myself to check the specs.
Flags: needinfo?(mozillamarcia.knous)
(Reporter)

Comment 3

3 years ago
The link to the failed test case above is incorrect. 
The correct failed case is: https://moztrap.mozilla.org/manage/case/11851/
According to the Adding to Home Screen from Rocket Bar section of the spec, this is working as designed now that the Edit Bookmark has been changed visually.

See page 27 of https://mozilla.app.box.com/s/jw7wgne4esbg9ccgx00s/1/2243605137/20745078519/1.

The test case will need to be updated.
Resolving this as invalid since this has been implemented to spec.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mozillamarcia.knous) → in-moztrap?(mozillamarcia.knous)
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
test case in Comment 3 updated to reflect new behavior.
Flags: in-moztrap?(mozillamarcia.knous) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.