Update should warn on mac if .app file isn't user-writable, instead of silently failing to open the update file for download

RESOLVED DUPLICATE of bug 1171792

Status

()

RESOLVED DUPLICATE of bug 1171792
5 years ago
4 years ago

People

(Reporter: jya, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8487639 [details]
Screen Shot 2014-09-11 at 11.25.20 am.png

This occurs on all my machines (all mac), no matter the version (I've had this happening for close to a year).

I have recently upgraded to Aurora 34, same deal. 

When a pop-up appears prompting that a new version of firefox is available and you click on the update button, it shows a progress bar with "Download Firefox" "Connecting to the update server".
This never completes.

I have to manually download the full image, and re-install it.

I use IPv6 via a HE.net tunnel if that makes a difference.
(Reporter)

Comment 1

5 years ago
Created attachment 8487640 [details]
Screen Shot 2014-09-11 at 11.25.31 am.png

Comment 2

5 years ago
Can you try manually connecting to https://aus3.mozilla.org/ ? Presumably that stalls in a similar way?

Can you also try, when this happens, opening the browser console (tools > web developer > browser console) and checking if any errors show up when Firefox gets "stuck" trying to connect to the update server?
Flags: needinfo?(jyavenard)
(Reporter)

Comment 3

5 years ago
Hi.

it connects fine and redirect to https://www.mozilla.org/en-US/

Will report on the console, going to restart aurora now
Flags: needinfo?(jyavenard)
(Reporter)

Comment 4

5 years ago
As soon as I click on the "Update Aurora" button, the following message appear in the consore:

NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.create] FileUtils.jsm:70

FirefoxAurora.app isn't located in the /Applications folder, but instead in /Applications/Custom/Web\ Browsers

After relocating FirefoxAurora.app into the /Applications folder, I see that it now download the updates and automatically updated.

So I guess the issue appears when the application isn't located in /Applications
(Reporter)

Comment 5

5 years ago
Interestingly.

I moved FirefoxAurora.app from the /Applications/Custom/Web\ Browsers/ into /Applications/ ; this didn't require me to authenticate to move the application.

I then moved it back to /Applications/Custom/Web\ Browsers, was asked to authenticate for the move to proceed.
After that, when I started the application, I had to confirm that I was okay to run the app (Apple security thingy). Started properly, and now it updates !

So it appears to be related to permissions of some kind...
Maybe an error message of some kind rather than hanging forever would be preferred

Comment 6

5 years ago
What kind of permission bits are set on the /Applications/Custom/Web\ Browsers/ folder?
(Reporter)

Comment 7

5 years ago
jyamba:git jyavenard$ ls -la /Applications/Custom/Web\ Browsers/
total 48
drwxrwxr-x+ 19 root       wheel    646 11 Sep 19:26 .
drwxrwxr-x+ 29 root       wheel    986 27 Sep  2012 ..
-rwxrwxr--+  1 root       wheel  15364 13 Nov  2013 .DS_Store
drwxrwxr-x+  3 root       wheel    102 10 Apr  2008 Camino.app
drwxrwxr-x+  4 root       wheel    136 14 Mar  2011 Chrome SPNEGO.app
drwxrwxr-x+  3 root       wheel    102 26 Oct  2007 Firefox 2.app
drwxrwxr-x+  3 root       wheel    102  6 Mar  2011 Firefox 3.6.app
drwxrwxr-x+  3 root       wheel    102 10 Jun  2008 Firefox 3.app
drwxr-xr-x@  4 root       wheel    136 17 Jul 14:12 Firefox.app
drwxr-xr-x@  4 jyavenard  admin    136 11 Sep 19:27 FirefoxAurora.app
drwxrwxr-x@  3 jyavenard  admin    102 20 Aug 06:13 Google Chrome.app

I see... Move the file back and forth changed the owner to myself, which explain why suddenly it worked.

Deleting the application, and copying once again from the installation dmg:

drwxr-xr-x@  4 root       wheel    136  8 Sep 20:52 FirefoxAurora.app

and once again, auto update fails.

Changing the ownership of the application back to my name, auto update now works.

Updated

5 years ago
Component: General → Application Update
Product: Firefox → Toolkit
Summary: Auto update never completes → Update should warn on mac if .app file isn't user-writable, instead of silently failing to open the update file for download
Version: unspecified → Trunk
This was due to bug 1171792 and the fix should be available after updating to Firefox 39.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171792
You need to log in before you can comment on or make changes to this bug.